CVE-2001-1207
CVSS7.5
发布时间 :2001-12-30 00:00:00
修订时间 :2008-09-05 16:25:57
NMCOS    

[原文]Buffer overflows in DayDream BBS 2.9 through 2.13 allow remote attackers to possibly execute arbitrary code via the control codes (1) ~#MC, (2) ~#TF, or (3) ~#RA.


[CNNVD]DayDream BBS控制代码多处缓冲区溢出漏洞(CNNVD-200112-149)

        
        DayDream BBS原来用于AmigaOS,现在它被移植到Linux和一些基于BSD的系统。DayDream BBS支持会议、消息板、文件传输等功能。
        DayDream的实现上存在一些缓冲区溢出漏洞,远程攻击者可以利用这些漏洞在主机上执行任意指令。
        DayDream支持包含在文本文件中的控制代码,这些代码可以用来加入额外的信息或执行一些其他的功能,其中的一些控制代码当它们被输入超长字串的参数时会导致缓冲区溢出,从而执行任意指令。如果攻击者在所贴的贴子里放入这些控制代码,则可能在服务器上执行任意指令,在默认推荐的安装环境下,攻击者可以得到"BBS"用户权限。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:daydream:daydream_bbs:2.13
cpe:/a:daydream:daydream_bbs:2.12
cpe:/a:daydream:daydream_bbs:2.10
cpe:/a:daydream:daydream_bbs:2.9

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1207
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1207
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-149
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/3757
(VENDOR_ADVISORY)  BID  3757
http://www.iss.net/security_center/static/7755.php
(VENDOR_ADVISORY)  XF  daydream-bbs-control-code-bo(7755)

- 漏洞信息

DayDream BBS控制代码多处缓冲区溢出漏洞
高危 边界条件错误
2001-12-30 00:00:00 2005-10-20 00:00:00
远程  
        
        DayDream BBS原来用于AmigaOS,现在它被移植到Linux和一些基于BSD的系统。DayDream BBS支持会议、消息板、文件传输等功能。
        DayDream的实现上存在一些缓冲区溢出漏洞,远程攻击者可以利用这些漏洞在主机上执行任意指令。
        DayDream支持包含在文本文件中的控制代码,这些代码可以用来加入额外的信息或执行一些其他的功能,其中的一些控制代码当它们被输入超长字串的参数时会导致缓冲区溢出,从而执行任意指令。如果攻击者在所贴的贴子里放入这些控制代码,则可能在服务器上执行任意指令,在默认推荐的安装环境下,攻击者可以得到"BBS"用户权限。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时停止此程序的使用。
        厂商补丁:
        DayDream
        --------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://daydream.iwn.fi/

- 漏洞信息

14225
DayDream BBS Control Code Arbitrary Code Execution
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-12-30 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

DayDream BBS Control Code Multiple Buffer Overflow Vulnerability
Boundary Condition Error 3757
Yes No
2001-12-30 12:00:00 2009-07-12 05:56:00
Reported by KF <dotslash@snosoft.com> in a posting to the BugTraq mailing list on December 30, 2001.

- 受影响的程序版本

DayDream DayDream BBS 2.13
DayDream DayDream BBS 2.12
DayDream DayDream BBS 2.10
DayDream DayDream BBS 2.9

- 漏洞讨论

DayDream BBS was originally written for AmigaOS, although a port is now actively maintained for Linux and BSD based systems. DayDream is conference based, and includes support for message boards, file transfers, and doors.

DayDream supports control codes included in text files, which are used to insert additional information and to perform some actions. Some of these control codes can lead to buffer overflows when they are passed extremely large parameters. This may lead to the execution of arbitrary code.

If a user is able to include these control codes in posted messages, it may be possible for a remote user of the BBS system to cause arbitrary code to be executed. Under the recommended installation, this will be as the non-privileged user 'bbs'.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

There have been reports that this vulnerability is fixed in the most recent release of DayDream BBS.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站