发布时间 :2001-12-30 00:00:00
修订时间 :2016-10-17 22:14:18

[原文]Matrix CGI vault Last Lines 2.0 allows remote attackers to execute arbitrary commands via shell metacharacters in the $error_log variable.

[CNNVD]Last Lines CGI脚本执行任意命令漏洞(CNNVD-200112-147)

        Last Lines CGI是一个免费的脚本,用Perl实现,由Matrix's CGI Vault维护。它可以使用户打印出Web日志文件尾部中某些指定的行。
        # $unixdir="path/here";
        # $error_log是用户输入的值
        open(FILE, "$unix_dir/$error_log"

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20011230 lastlines.cgi path traversal and command execution vulns

- 漏洞信息

Last Lines CGI脚本执行任意命令漏洞
高危 输入验证
2001-12-30 00:00:00 2007-03-30 00:00:00
        Last Lines CGI是一个免费的脚本,用Perl实现,由Matrix's CGI Vault维护。它可以使用户打印出Web日志文件尾部中某些指定的行。
        # $unixdir="path/here";
        # $error_log是用户输入的值
        open(FILE, "$unix_dir/$error_log"

- 公告与补丁

        * 暂时停止此程序的使用。
        Matrix's CGI Vault

- 漏洞信息

Matrix CGI vault Last Lines Arbitrary Command Execution

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-12-30 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Last Lines CGI Script Remote Command Execution Vulnerability
Input Validation Error 3755
Yes No
2001-12-30 12:00:00 2009-07-11 09:06:00
This vulnerability was submitted to BugTraq on December 30th, 2001 by BrainRawt <>.

- 受影响的程序版本

Matrix's CGI vault Last Lines 2.0
- Apache Software Foundation Apache 1.3.22
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.19
- Apache Software Foundation Apache 1.3.18
- Apache Software Foundation Apache 1.3.17

- 漏洞讨论

Last Lines CGI is a freely available script written in Perl and maintained by the Matrix's CGI Vault. It allows the user to print a specified number of lines from the end of a log file(or any text file) to a webpage. It can run on Linux and Unix systems or any other platform with Apache and Perl support.

Lastlines.cgi does not filter shell metacharacters from web requests. As a result, it is possible for a remote attacker to execute commands on the shell of a host running the vulnerable script. Commands will be executed with the privileges of the webserver process.

This impact of this vulnerability is that an attacker may gain local, interactive access to the host.

- 漏洞利用

This vulnerability can be exploited with a web browser.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考