CVE-2001-1203
CVSS7.2
发布时间 :2001-12-27 00:00:00
修订时间 :2008-09-10 15:09:54
NMCO    

[原文]Format string vulnerability in gpm-root in gpm 1.17.8 through 1.17.18 allows local users to gain root privileges.


[CNNVD]gpm-root本地格式串漏洞(CNNVD-200112-141)

        
        gpm(General Mouse Protocol)是一个由公共域维护的鼠标驱动软件,它是免费并开放源码的,运行于Linux和其它类UNIX平台。
        gpm的实现存在格式串漏洞,可以使本地攻击者通过溢出攻击在主机上执行任意指令。
        gpm没有正确地处理用户提交的格式串,一个用户可以提供任意的格式串给gpm-root程序,从而导致执行攻击者指定的任意指令。gpm程序是由init进程以root身份运行的,所以攻击者可以利用这个漏洞得到主机的管理员权限。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:alessandro_rubini:gpm:1.17.18
cpe:/o:alessandro_rubini:gpm:1.17.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1203
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1203
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-141
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2001/dsa-095
(VENDOR_ADVISORY)  DEBIAN  DSA-095
http://xforce.iss.net/xforce/xfdb/7748
(UNKNOWN)  XF  linux-gpm-format-string(7748)
http://www.securityfocus.com/bid/3750
(UNKNOWN)  BID  3750

- 漏洞信息

gpm-root本地格式串漏洞
高危 输入验证
2001-12-27 00:00:00 2005-09-14 00:00:00
本地  
        
        gpm(General Mouse Protocol)是一个由公共域维护的鼠标驱动软件,它是免费并开放源码的,运行于Linux和其它类UNIX平台。
        gpm的实现存在格式串漏洞,可以使本地攻击者通过溢出攻击在主机上执行任意指令。
        gpm没有正确地处理用户提交的格式串,一个用户可以提供任意的格式串给gpm-root程序,从而导致执行攻击者指定的任意指令。gpm程序是由init进程以root身份运行的,所以攻击者可以利用这个漏洞得到主机的管理员权限。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时停止gpm-root的程序的使用。
        厂商补丁:
        Debian
        ------
        Debian已经为此发布了一个安全公告(DSA-095-1)以及相应补丁:
        DSA-095-1:gpm local root vulnerability
        链接:
        http://www.debian.org/security/2001/dsa-095

        补丁下载:
        Debian GNU/Linux 2.2 (potato)
        Source:
        
        http://security.debian.org/dists/stable/updates/main/source/gpm_1.17.8-18.1.diff.gz

        
        http://security.debian.org/dists/stable/updates/main/source/gpm_1.17.8-18.1.dsc

        
        http://security.debian.org/dists/stable/updates/main/source/gpm_1.17.8.orig.tar.gz

        Alpha:
        
        http://security.debian.org/dists/stable/updates/main/binary-alpha/gpm_1.17.8-18.1_alpha.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-alpha/libgpmg1-dev_1.17.8-18.1_alpha.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-alpha/libgpmg1_1.17.8-18.1_alpha.deb

        ARM:
        
        http://security.debian.org/dists/stable/updates/main/binary-arm/gpm_1.17.8-18.1_arm.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-arm/libgpmg1-dev_1.17.8-18.1_arm.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-arm/libgpmg1_1.17.8-18.1_arm.deb

        Intel IA-32:
        
        http://security.debian.org/dists/stable/updates/main/binary-i386/gpm_1.17.8-18.1_i386.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-i386/libgpm1-altdev_1.17.8-18.1_i386.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-i386/libgpm1_1.17.8-18.1_i386.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-i386/libgpmg1-dev_1.17.8-18.1_i386.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-i386/libgpmg1_1.17.8-18.1_i386.deb

        Motorola 680x0:
        
        http://security.debian.org/dists/stable/updates/main/binary-m68k/gpm_1.17.8-18.1_m68k.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-m68k/libgpm1-altdev_1.17.8-18.1_m68k.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-m68k/libgpm1_1.17.8-18.1_m68k.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-m68k/libgpmg1-dev_1.17.8-18.1_m68k.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-m68k/libgpmg1_1.17.8-18.1_m68k.deb

        PowerPC:
        
        http://security.debian.org/dists/stable/updates/main/binary-powerpc/gpm_1.17.8-18.1_powerpc.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-powerpc/libgpmg1-dev_1.17.8-18.1_powerpc.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-powerpc/libgpmg1_1.17.8-18.1_powerpc.deb

        Sun Sparc:
        
        http://security.debian.org/dists/stable/updates/main/binary-sparc/gpm_1.17.8-18.1_sparc.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-sparc/libgpmg1-dev_1.17.8-18.1_sparc.deb

        
        http://security.debian.org/dists/stable/updates/main/binary-sparc/libgpmg1_1.17.8-18.1_sparc.deb

- 漏洞信息

2013
gpm-root Format String Privilege Escalation
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2001-12-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.17.8-18.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站