CVE-2001-1199
CVSS7.5
发布时间 :2001-12-17 00:00:00
修订时间 :2008-09-05 16:25:56
NMCOE    

[原文]Cross-site scripting vulnerability in agora.cgi for Agora 3.0a through 4.0g, when debug mode is enabled, allows remote attackers to execute Javascript on other clients via the cart_id parameter.


[CNNVD]Agora.CGI跨站脚本执行漏洞(CNNVD-200112-110)

        
        Agora.cgi是一个免费,开放源码的网上售货系统。
        Agora.cgi存在跨站脚本执行漏洞,可以使攻击者通过窃取Cookie等手段获得敏感信息。
        攻击者可以在运行了Agora.cgi的Web页面上放置包含了任意脚本代码的链接,用户如果点击了该链接,则脚本就会在用户Web浏览器环境下执行。攻击者可能借此收集到用户当前的Cookie,这些Cookie中可能包含有敏感信息。已经证实3.3e版的软件是有此问题的,其它以下的低版本可能也有此问题。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:steve_kneizys:agora.cgi:3.2g
cpe:/a:steve_kneizys:agora.cgi:3.2q
cpe:/a:steve_kneizys:agora.cgi:3.2b
cpe:/a:steve_kneizys:agora.cgi:3.3a
cpe:/a:steve_kneizys:agora.cgi:3.3b
cpe:/a:steve_kneizys:agora.cgi:3.3i
cpe:/a:steve_kneizys:agora.cgi:4.0d
cpe:/a:steve_kneizys:agora.cgi:3.2p
cpe:/a:steve_kneizys:agora.cgi:3.2i
cpe:/a:steve_kneizys:agora.cgi:3.3j
cpe:/a:steve_kneizys:agora.cgi:3.2c
cpe:/a:steve_kneizys:agora.cgi:3.2ja
cpe:/a:steve_kneizys:agora.cgi:3.2e
cpe:/a:steve_kneizys:agora.cgi:3.2d
cpe:/a:steve_kneizys:agora.cgi:3.2m
cpe:/a:steve_kneizys:agora.cgi:3.3c
cpe:/a:steve_kneizys:agora.cgi:3.3d
cpe:/a:steve_kneizys:agora.cgi:3.2h
cpe:/a:steve_kneizys:agora.cgi:3.2
cpe:/a:steve_kneizys:agora.cgi:3.2f
cpe:/a:steve_kneizys:agora.cgi:4.0c
cpe:/a:steve_kneizys:agora.cgi:3.3f
cpe:/a:steve_kneizys:agora.cgi:3.2n
cpe:/a:steve_kneizys:agora.cgi:3.3e
cpe:/a:steve_kneizys:agora.cgi:3.2l
cpe:/a:steve_kneizys:agora.cgi:4.0b
cpe:/a:steve_kneizys:agora.cgi:3.2j
cpe:/a:steve_kneizys:agora.cgi:3.2k
cpe:/a:steve_kneizys:agora.cgi:4.0
cpe:/a:steve_kneizys:agora.cgi:3.2r
cpe:/a:steve_kneizys:agora.cgi:4.0a
cpe:/a:steve_kneizys:agora.cgi:3.2a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1199
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1199
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-110
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/3702
(VENDOR_ADVISORY)  BID  3702
http://www.securityfocus.com/archive/1/246044
(VENDOR_ADVISORY)  BUGTRAQ  20011217 Agoracgi v3.3e Cross Site Scripting Vulnerability
http://www.iss.net/security_center/static/7708.php
(VENDOR_ADVISORY)  XF  agora-cgi-css(7708)
http://www.agoracgi.com/security.html
(UNKNOWN)  CONFIRM  http://www.agoracgi.com/security.html
http://www.osvdb.org/698
(UNKNOWN)  OSVDB  698

- 漏洞信息

Agora.CGI跨站脚本执行漏洞
高危 未知
2001-12-17 00:00:00 2005-05-02 00:00:00
远程  
        
        Agora.cgi是一个免费,开放源码的网上售货系统。
        Agora.cgi存在跨站脚本执行漏洞,可以使攻击者通过窃取Cookie等手段获得敏感信息。
        攻击者可以在运行了Agora.cgi的Web页面上放置包含了任意脚本代码的链接,用户如果点击了该链接,则脚本就会在用户Web浏览器环境下执行。攻击者可能借此收集到用户当前的Cookie,这些Cookie中可能包含有敏感信息。已经证实3.3e版的软件是有此问题的,其它以下的低版本可能也有此问题。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 在IE中禁止活动脚本及ActiveX控件的执行。
        厂商补丁:
        Steve Kneizys
        -------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.agoracgi.com

- 漏洞信息 (21184)

Agora.CGI 3.x/4.0 Debug Mode Cross-Site Scripting Vulnerability (EDBID:21184)
cgi webapps
2001-12-17 Verified
0 Tamer Sahin
N/A [点击下载]
source: http://www.securityfocus.com/bid/3702/info

Agora.cgi is a freely available, open source shopping cart system.

When debug mode is enabled, the Agora.cgi script does not adequately filter HTML tags when debug information is being output. Debug mode is not enabled by default and must be explicitly turned on by an administrator.

As a result, it is possible for an attacker to construct a link to the script that includes maliciously constructed script code. When the link is clicked by a web user, the script code will be executed by the client in the context of the site running Agora.cgi.

This issue may be exploited to by an attacker to steal cookie-based authentication credentials, permitting the attacker to hijack an Agora.cgi session and perform actions as a legitimate user. A number of other cross-site scripting attacks are also possible.

http://agorasite/store/agora.cgi?cart_id=<script>alert(document.cookie)</script>&xm=on&product=HTML 		

- 漏洞信息

698
AgoraCart agora.cgi cart_id Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Third-party Verified

- 漏洞描述

AgoraCart contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "cart_id" variable upon submission to the agora.cgi script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2001-12-17 Unknow
2001-12-17 Unknow

- 解决方案

Upgrade to version 4.0k or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站