CVE-2001-1189
CVSS4.6
发布时间 :2001-12-13 00:00:00
修订时间 :2008-09-05 16:25:54
NMCOS    

[原文]IBM Websphere Application Server 3.5.3 and earlier stores a password in cleartext in the sas.server.props file, which allows local users to obtain the passwords via a JSP script.


[CNNVD]IBM WebSphere JSP根密码泄露漏洞(CNNVD-200112-099)

        IBM Websphere Application Server 3.5.3及其早期版本在sas.server.props文件中以明文方式存储密码,本地用户借助JSP脚本获取密码。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ibm:websphere_application_server:3.0IBM WebSphere Application Server 3.0
cpe:/a:ibm:websphere_application_server:3.0.2.4IBM WebSphere Application Server 3.0.2.4
cpe:/a:ibm:websphere_application_server:3.5IBM WebSphere Application Server 3.5
cpe:/a:ibm:websphere_application_server:3.0.2.3IBM WebSphere Application Server 3.0.2.3
cpe:/a:ibm:websphere_application_server:3.0.2IBM WebSphere Application Server 3.0.2
cpe:/a:ibm:websphere_application_server:3.5.3IBM WebSphere Application Server 3.5.3
cpe:/a:ibm:websphere_application_server:3.5.1IBM WebSphere Application Server 3.5.1
cpe:/a:ibm:websphere_application_server:3.5.2IBM WebSphere Application Server 3.5.2
cpe:/a:ibm:websphere_application_server:3.0.2.1IBM WebSphere Application Server 3.0.2.1
cpe:/a:ibm:websphere_application_server:3.0.2.2IBM WebSphere Application Server 3.0.2.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1189
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1189
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-099
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/3682
(VENDOR_ADVISORY)  BID  3682
http://www.securityfocus.com/archive/1/245324
(VENDOR_ADVISORY)  BUGTRAQ  20011213 IBM WebSphere on UNIX security alert !
http://www.iss.net/security_center/static/7698.php
(VENDOR_ADVISORY)  XF  websphere-java-plaintext-passwords(7698)

- 漏洞信息

IBM WebSphere JSP根密码泄露漏洞
中危 设计错误
2001-12-13 00:00:00 2005-10-20 00:00:00
本地  
        IBM Websphere Application Server 3.5.3及其早期版本在sas.server.props文件中以明文方式存储密码,本地用户借助JSP脚本获取密码。

- 公告与补丁

        Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息

9679
IBM WebSphere Application Server (WAS) sas.server.props Cleartext Password Disclosure
Cryptographic, Information Disclosure
Loss of Confidentiality

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-12-13 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

IBM WebSphere JSP Root Password Disclosure Vulnerability
Design Error 3682
No Yes
2001-12-13 12:00:00 2009-07-11 09:06:00
This vulnerability was submitted to BugTraq on December 13th, 2001 by Heikki Tunkelo <heikki.tunkelo@erln.gepas.de>.

- 受影响的程序版本

IBM Websphere Application Server 3.5.3
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Sun Solaris 8_sparc
IBM Websphere Application Server 3.5.2
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Sun Solaris 8_sparc
IBM Websphere Application Server 3.5.1
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Sun Solaris 8_sparc
IBM Websphere Application Server 3.5
IBM Websphere Application Server 3.0.2 .1
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Sun Solaris 8_sparc
IBM Websphere Application Server 3.0.2
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Sun Solaris 8_sparc
IBM Websphere Application Server 3.0 .2.4
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Sun Solaris 8_sparc
IBM Websphere Application Server 3.0 .2.3
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Sun Solaris 8_sparc
IBM Websphere Application Server 3.0 .2.2
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Sun Solaris 8_sparc
IBM Websphere Application Server 3.0
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Novell Netware 5.0
- Sun Solaris 8_sparc

- 漏洞讨论

IBM WebSphere is a commercial web application server which runs on a number of platforms.

The root password for AIX, Linux and Sun systems is stored plaintext in a file called $WASROOT/properties/sas.server.props, which is not readable by non-root users. However, IBM WebSphere normally runs as root in default installations. In addition, all Java code on a host running IBM WebSphere is also executed with root privileges. This leaves an opening whereby an unprivileged local attacker could create a JSP script which could read the root password from $WASROOT/properties/sas.server.props to gain elevated privileges.

There are a number of other security implications that arise from a local unprivileged user being able to execute arbitrary code as root, all resulting in an escalation of privileges. Additionally, with the default configuration, hosts running IBM WebSphere may be vulnerable to a remote root compromise in cases where a remotely exploitable vulnerability allows arbitrary code execution.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站