CVE-2001-1146
CVSS1.2
发布时间 :2001-07-11 00:00:00
修订时间 :2008-09-10 15:09:45
NMCO    

[原文]AllCommerce with debugging enabled in EnGarde Secure Linux 1.0.1 creates temporary files with predictable names, which allows local users to modify files via a symlink attack.


[CNNVD]AllCommerce 符号链接漏洞(CNNVD-200107-072)

        CVE(CAN) ID: CVE-2001-1146
        
        
        
        AllCommerce是EnGarde Secure Linux附带的一款免费,开放源代码的电子商务软件。
        
        
        
        其缺省为打开调试模式,但是在调试模式下,AllCommerce会在/tmp目录下创建不安全
        
        的临时文件.由于没有检查目标文件是否存在,而且临时文件名是可以预知的,因此容易受
        
        到符号链接攻击。
        
        
        
        攻击者利用这个漏洞,可能造成文件破坏,数据丢失,拒绝服务,或者是提升权限,但
        
        是攻击者必须在本地利用这个漏洞。
        
        
        
        

- CVSS (基础分值)

CVSS分值: 1.2 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1146
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1146
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200107-072
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/6830.php
(VENDOR_ADVISORY)  XF  allcommerce-temp-symlink(6830)
http://www.linuxsecurity.com/advisories/other_advisory-1492.html
(VENDOR_ADVISORY)  ENGARDE  ESA-20010711-01
http://www.securityfocus.com/bid/3016
(UNKNOWN)  BID  3016

- 漏洞信息

AllCommerce 符号链接漏洞
低危 竞争条件
2001-07-11 00:00:00 2005-05-02 00:00:00
本地  
        CVE(CAN) ID: CVE-2001-1146
        
        
        
        AllCommerce是EnGarde Secure Linux附带的一款免费,开放源代码的电子商务软件。
        
        
        
        其缺省为打开调试模式,但是在调试模式下,AllCommerce会在/tmp目录下创建不安全
        
        的临时文件.由于没有检查目标文件是否存在,而且临时文件名是可以预知的,因此容易受
        
        到符号链接攻击。
        
        
        
        攻击者利用这个漏洞,可能造成文件破坏,数据丢失,拒绝服务,或者是提升权限,但
        
        是攻击者必须在本地利用这个漏洞。
        
        
        
        

- 公告与补丁

        
        
        请升级到最新版本
        
        
        
        厂商补丁:
        
        
        
        Guardian Digital已经发布了升级版本来解决这个安全问题:
        
        
        
        Guardian Digital upgrade AllCommerce-1.0.4.1-1.0.25.noarch.rpm
        
        ftp://ftp.engardelinux.org/pub/engarde/stable/updates/
        

- 漏洞信息

1900
AllCommerce Symlink Arbitrary File Modification
Local Access Required Race Condition

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-07-11 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站