CVE-2001-1089
CVSS7.5
发布时间 :2001-09-10 00:00:00
修订时间 :2008-09-05 16:25:39
NMCO    

[原文]libnss-pgsql in nss-pgsql 0.9.0 and earlier allows remote attackers to execute arbitrary SQL queries by inserting SQL code into an HTTP request.


[CNNVD]nss-pgsqlSQL查询受到威胁(CNNVD-200109-034)

        nss-pgsql 0.9.0及其早期版本中的libnss-pgsql存在漏洞。远程攻击者可以通过向HTTP请求中注入SQL代码执行任意SQL查询。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:joerg_wendland:libnss-pgsql:0.9.0
cpe:/a:alessandro_gardich:nss_postgresql:0.6.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1089
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1089
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200109-034
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/7111.php
(VENDOR_ADVISORY)  XF  postgresql-nss-authentication-modules(7111)
http://www.securityfocus.com/bid/3314
(VENDOR_ADVISORY)  BID  3314
http://www.securityfocus.com/archive/1/213331
(VENDOR_ADVISORY)  BUGTRAQ  20010910 RUS-CERT Advisory 2001-09:01

- 漏洞信息

nss-pgsqlSQL查询受到威胁
高危 未知
2001-09-10 00:00:00 2005-05-02 00:00:00
远程  
        nss-pgsql 0.9.0及其早期版本中的libnss-pgsql存在漏洞。远程攻击者可以通过向HTTP请求中注入SQL代码执行任意SQL查询。

- 公告与补丁

        

- 漏洞信息

1950
Joerg Wendland LibNSS-PgSQL Remote SQL Query Manipulation
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2001-09-10 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站