CVE-2001-1074
CVSS7.2
发布时间 :2001-05-28 00:00:00
修订时间 :2008-09-05 16:25:37
NMCO    

[原文]Webmin 0.84 and earlier does not properly clear the HTTP_AUTHORIZATION environment variable when the web server is restarted, which makes authentication information available to all CGI programs and allows local users to gain privileges.


[CNNVD]Webmin提升特权漏洞(CNNVD-200105-102)

        Webmin 0.84及其早期版本在web服务器重启后不正确的清除HTTP_AUTHORIZATION环境变量,该漏洞给所有的CGI程序提供认证信息变量且本地用户利用该漏洞提升特权。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:webmin:webmin:0.83
cpe:/a:webmin:webmin:0.7
cpe:/a:webmin:webmin:0.84
cpe:/a:webmin:webmin:0.5
cpe:/a:webmin:webmin:0.6
cpe:/a:webmin:webmin:0.80

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-1074
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-1074
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200105-102
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/6627.php
(VENDOR_ADVISORY)  XF  webmin-gain-information(6627)
http://www.securityfocus.com/bid/2795
(VENDOR_ADVISORY)  BID  2795
http://www.linux-mandrake.com/en/security/2001/MDKSA-2001-059.php3
(PATCH)  MANDRAKE  MDKSA-2001:059
http://www.calderasystems.com/support/security/advisories/CSSA-2001-019.1.txt
(VENDOR_ADVISORY)  CALDERA  CSSA-2001-019.1
http://archives.neohapsis.com/archives/bugtraq/2001-05/0262.html
(VENDOR_ADVISORY)  BUGTRAQ  20010526 Webmin Doesn't Clean Env (root exploit)

- 漏洞信息

Webmin提升特权漏洞
高危 未知
2001-05-28 00:00:00 2005-05-02 00:00:00
本地  
        Webmin 0.84及其早期版本在web服务器重启后不正确的清除HTTP_AUTHORIZATION环境变量,该漏洞给所有的CGI程序提供认证信息变量且本地用户利用该漏洞提升特权。

- 公告与补丁

        

- 漏洞信息

1844
Webmin miniserv.pl Environment Variable Cleartext Password Local Disclosure
Local Access Required Information Disclosure
Loss of Confidentiality Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2001-03-27 Unknow
Unknow 2001-03-27

- 解决方案

Upgrade to version 0.85 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站