CVE-2001-0996
CVSS6.4
发布时间 :2001-09-02 00:00:00
修订时间 :2008-09-05 16:25:25
NMCOS    

[原文]POP3Lite before 0.2.4 does not properly quote a . (dot) in an email message, which could allow a remote attacker to append arbitrary text to the end of an email message, which could then be interpreted by various mail clients as valid POP server responses or other input that could cause clients to crash or otherwise behave unexpectedly.


[CNNVD]POP3Lite 输入验证漏洞(CNNVD-200109-001)

        CVE(CAN) ID: CAN-2001-0996
        
        
        
        POP3Lite是Linux和BSD平台下的免费,开放源代码的POP3守护程序。
        
        
        
        发现POP3Lite没有过滤信件中以"."开始的行,这至少可能导致意外情况的发生,如
        
        果我们精心构造这封信件的内容,就可能导致把任意伪造的系统相应信息发送给从该服
        
        务器上下载邮件的用户。
        
        
        
        远程攻击者利用这个漏洞,可能插入任意信息或导致信息丢失,也可能导致匿名Email
        
        攻击或者是拒绝服务攻击,这取决于客户端如何解释这些而已的输入。
        
        
        
        

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:pop3lite:pop3lite:0.2.3
cpe:/a:pop3lite:pop3lite:0.2.3b

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0996
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0996
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200109-001
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/7075.php
(VENDOR_ADVISORY)  XF  pop3lite-dot-message-injection(7075)
http://www.securityfocus.com/bid/3278
(VENDOR_ADVISORY)  BID  3278
http://archives.neohapsis.com/archives/bugtraq/2001-08/0436.html
(VENDOR_ADVISORY)  BUGTRAQ  20010902 POP3Lite 0.2.3b minor client side DoS and message injection

- 漏洞信息

POP3Lite 输入验证漏洞
中危 输入验证
2001-09-02 00:00:00 2005-10-20 00:00:00
远程  
        CVE(CAN) ID: CAN-2001-0996
        
        
        
        POP3Lite是Linux和BSD平台下的免费,开放源代码的POP3守护程序。
        
        
        
        发现POP3Lite没有过滤信件中以"."开始的行,这至少可能导致意外情况的发生,如
        
        果我们精心构造这封信件的内容,就可能导致把任意伪造的系统相应信息发送给从该服
        
        务器上下载邮件的用户。
        
        
        
        远程攻击者利用这个漏洞,可能插入任意信息或导致信息丢失,也可能导致匿名Email
        
        攻击或者是拒绝服务攻击,这取决于客户端如何解释这些而已的输入。
        
        
        
        

- 公告与补丁

        
        
        厂商补丁:
        
        
        
        POP3Lite 0.2.4已经修正了这个问题,请立即到厂商的主页下载:
        
        
        
        POP3Lite upgrade POP3Lite
        
        ftp://pop3lite.sourceforge.net/pub/pop3lite/
        
        
        
        Debian upgrade POP3Lite 0.4.2a-1 unstable
        
        
        http://packages.debian.org/unstable/mail/pop3lite.html

        

- 漏洞信息

14078
POP3Lite Single Dot Message POP Client Command Injection
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

POP3Lite contains a flaw that may allow a malicious user to inject arbitrary messages into users mailboxes, or delete messages from users mailboxes. The issue is triggered when the POP3Lite server fails to escape a leading single dot "." from email messages. It is possible that the flaw may allow arbitrary message deletion or injection resulting in a loss of integrity.

- 时间线

2001-09-03 Unknow
2001-09-03 Unknow

- 解决方案

Upgrade to version 0.2.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

POP3Lite Input Validation Vulnerability
Input Validation Error 3278
Yes No
2001-09-03 12:00:00 2009-07-11 07:56:00
This vulnerability disclosed by Daniel Roethlisberger <daniel@roe.ch> on September 3rd, 2001.

- 受影响的程序版本

POP3Lite POP3Lite 0.2.3 b
+ Debian Linux 2.2 r3 unstable
+ Debian Linux 2.2 r3 testing
- FreeBSD FreeBSD 5.0
POP3Lite POP3Lite 0.2.3
+ Debian Linux 2.2 r3 unstable
+ Debian Linux 2.2 r3 testing
- FreeBSD FreeBSD 5.0
POP3Lite POP3Lite 0.2.4
+ Debian Linux 2.2 r3 unstable
+ Debian Linux 2.2 r3 testing
- FreeBSD FreeBSD 5.0

- 不受影响的程序版本

POP3Lite POP3Lite 0.2.4
+ Debian Linux 2.2 r3 unstable
+ Debian Linux 2.2 r3 testing
- FreeBSD FreeBSD 5.0

- 漏洞讨论

POP3Lite is a free, open-source compact POP3 daemon for Linux and BSD systems.

POP3Lite has an input validation problem which may be exploited by remote attackers. POP3Lite will not escape leading dots('.') from e-mail it transfers. At the very least this may cause unusual behavior to occur, but may be manipulated to malicious effect. This may allow an attacker to pass arbitrary server responses to the mail client of a user retrieving mail from a POP3Lite server.

Remote attackers may exploit this issue to inject messages or cause messages to be lost. A potential for mail-spoofing attacks also exists as message headers can be falsified. A denial of services may also result, depending on how the client interprets the malicious input.

- 漏洞利用

An attacker need only compose an email with a '.'. Maliciously crafted fake server responses may follow in the body of the email message.

- 解决方案

The vendor has addressed this issue in version 0.2.4.


POP3Lite POP3Lite 0.2.3 b

POP3Lite POP3Lite 0.2.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站