CVE-2001-0977
CVSS5.0
发布时间 :2001-07-16 00:00:00
修订时间 :2008-09-05 16:25:22
NMCO    

[原文]slapd in OpenLDAP 1.x before 1.2.12, and 2.x before 2.0.8, allows remote attackers to cause a denial of service (crash) via an invalid Basic Encoding Rules (BER) length field.


[CNNVD]OpenLDAP slapd服务拒绝漏洞(CNNVD-200107-100)

        OpenLDAP 1.2.12之前1.x 版本以及2.0.8之前2.x版本中slapd存在漏洞。远程攻击者借助无效Basic Encoding Rules (BER) 长度字段导致服务拒绝。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:openldap:openldap:1.2.10
cpe:/a:openldap:openldap:1.2.8
cpe:/a:openldap:openldap:2.0.7
cpe:/o:mandrakesoft:mandrake_linux:8.0MandrakeSoft Mandrake Linux 8.0
cpe:/o:mandrakesoft:mandrake_linux:7.2MandrakeSoft Mandrake Linux 7.2
cpe:/a:openldap:openldap:2.0.6
cpe:/a:openldap:openldap:2.0
cpe:/a:openldap:openldap:1.2.11
cpe:/a:openldap:openldap:1.2.9
cpe:/a:openldap:openldap:1.0.1
cpe:/o:debian:debian_linux:2.2Debian Debian Linux 2.2
cpe:/a:openldap:openldap:2.0.4
cpe:/o:redhat:linux:7.1Red Hat Linux 7.1
cpe:/a:openldap:openldap:1.1.3
cpe:/o:mandrakesoft:mandrake_linux_corporate_server:1.0.1MandrakeSoft Mandrake Linux Corporate Server 1.0.1
cpe:/a:openldap:openldap:2.0.1
cpe:/a:openldap:openldap:1.2.2
cpe:/a:openldap:openldap:1.1.1
cpe:/a:openldap:openldap:2.0.5
cpe:/a:openldap:openldap:2.0.3
cpe:/a:openldap:openldap:2.0.2
cpe:/o:mandrakesoft:mandrake_linux:7.1MandrakeSoft Mandrake Linux 7.1
cpe:/a:openldap:openldap:1.2
cpe:/a:openldap:openldap:1.1.4
cpe:/a:openldap:openldap:1.0.2
cpe:/a:mandrakesoft:mandrake_single_network_firewall:7.2MandrakeSoft Mandrake Single Network Firewall 7.2
cpe:/a:openldap:openldap:1.2.5
cpe:/o:redhat:linux:6.2Red Hat Linux 6.2
cpe:/a:openldap:openldap:1.1.2
cpe:/a:openldap:openldap:1.2.3
cpe:/a:openldap:openldap:1.2.4
cpe:/a:openldap:openldap:1.2.1
cpe:/a:openldap:openldap:1.0.3
cpe:/a:openldap:openldap:1.2.6
cpe:/a:openldap:openldap:1.0
cpe:/a:openldap:openldap:1.2.7
cpe:/a:openldap:openldap:1.1
cpe:/a:openldap:openldap:1.2.12
cpe:/o:redhat:linux:7.0Red Hat Linux 7.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0977
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0977
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200107-100
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/935800
(VENDOR_ADVISORY)  CERT-VN  VU#935800
http://www.cert.org/advisories/CA-2001-18.html
(VENDOR_ADVISORY)  CERT  CA-2001-18
http://xforce.iss.net/static/6904.php
(VENDOR_ADVISORY)  XF  openldap-ldap-protos-dos(6904)
http://www.securityfocus.com/bid/3049
(VENDOR_ADVISORY)  BID  3049
http://www.linux-mandrake.com/en/security/2001/MDKSA-2001-069.php3
(VENDOR_ADVISORY)  MANDRAKE  MDKSA-2001:069
http://www.redhat.com/support/errata/RHSA-2001-098.html
(UNKNOWN)  REDHAT  RHSA-2001:098
http://www.osvdb.org/1905
(UNKNOWN)  OSVDB  1905
http://www.debian.org/security/2001/dsa-068
(UNKNOWN)  DEBIAN  DSA-068
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000417
(UNKNOWN)  CONECTIVA  CLA-2001:417

- 漏洞信息

OpenLDAP slapd服务拒绝漏洞
中危 未知
2001-07-16 00:00:00 2005-05-02 00:00:00
远程  
        OpenLDAP 1.2.12之前1.x 版本以及2.0.8之前2.x版本中slapd存在漏洞。远程攻击者借助无效Basic Encoding Rules (BER) 长度字段导致服务拒绝。

- 公告与补丁

        

- 漏洞信息

1905
OpenLDAP slapd Invalid BER Length Field DoS
Denial of Service
Loss of Availability

- 漏洞描述

OpenLDAP contains a flaw that may allow a remote denial of service. The issue is triggered when an invalid length field in the Basic Encoding Rules (BER)is sent, and will result in loss of availability for the service.

- 时间线

2001-07-16 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2.12 or 2.0.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站