CVE-2001-0923
CVSS7.2
发布时间 :2001-10-25 00:00:00
修订时间 :2008-09-05 16:25:14
NMCOS    

[原文]RPM Package Manager 4.0.x through 4.0.2.x allows an attacker to execute arbitrary code via corrupted data in the RPM file when the file is queried.


[CNNVD]RedHat RPM 查询方式存在漏洞(CNNVD-200110-120)

        CVE(CAN) ID: CAN-2001-0923
        
        
        
        RedHat Package Management (RPM) 是系统用来打包,发布和安装软件的工具包,其
        
        4.0.2-7x版本存在一个安全问题,当恶意构造的RPM包被查询时,可能导致任意代码被
        
        执行。
        
        
        
        这个漏洞也影响使用rpm-4.0.x库文件的程序,包括rpm2html等。
        
        
        
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:redhat:redhat_package_manager:4.0.2-71Red Hat RPM 4.0.2_7.1
cpe:/a:redhat:redhat_package_manager:4.0.2-72Red Hat RPM 4.0.2_7.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0923
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0923
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200110-120
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/7349.php
(VENDOR_ADVISORY)  XF  Linux-rpm-execute-code(7349)
http://www.securityfocus.com/bid/3472
(VENDOR_ADVISORY)  BID  3472
http://www.securityfocus.com/archive/1/222542
(VENDOR_ADVISORY)  BUGTRAQ  20011025 Advisory: Corrupt RPM Query Vulnerability
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000440
(UNKNOWN)  CONECTIVA  CLA-2001:440

- 漏洞信息

RedHat RPM 查询方式存在漏洞
高危 边界条件错误
2001-10-25 00:00:00 2007-05-22 00:00:00
本地  
        CVE(CAN) ID: CAN-2001-0923
        
        
        
        RedHat Package Management (RPM) 是系统用来打包,发布和安装软件的工具包,其
        
        4.0.2-7x版本存在一个安全问题,当恶意构造的RPM包被查询时,可能导致任意代码被
        
        执行。
        
        
        
        这个漏洞也影响使用rpm-4.0.x库文件的程序,包括rpm2html等。
        
        
        
        

- 公告与补丁

        
        
        临时解决方法:
        
        
        
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        
        
        
        * 只查询可靠来源的RPM包
        
        
        
        厂商补丁:
        
        
        
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商
        
        的主页以获取最新版本:
        
        
        http://www.rpm.org/

- 漏洞信息

13992
Red Hat Package Manager (RPM) Malformed RPM File Arbitrary Code Execution
Loss of Integrity

- 漏洞描述

- 时间线

2001-10-25 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

RedHat RPM Corrupt Query Vulnerability
Boundary Condition Error 3472
No Yes
2001-10-24 12:00:00 2009-07-11 09:06:00
Discovered and posted to BugTraq by zen-parse <zen-parse@gmx.net> on October 24, 2001.

- 受影响的程序版本

RedHat RPM 4.0.2 -7x
+ Conectiva Linux 7.0
+ RedHat Linux 7.2
+ RedHat Linux 7.1

- 漏洞讨论

RedHat Package Management (RPM) is a system used to package, distribute and install software. A vulnerability exists in version 4.0.2-7x which causes arbitrary code to execute when a maliciously constructed package is queried.

This also affects programs using the rpm-4.0.x libraries, including rpm2html. It is possible that earlier 4.0.x packages are vulnerable.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Upgrades are available.


RedHat RPM 4.0.2 -7x

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站