发布时间 :2001-11-21 00:00:00
修订时间 :2016-10-17 22:13:11

[原文]PHP-Nuke 5.1 stores user and administrator passwords in a base-64 encoded cookie, which could allow remote attackers to gain privileges by stealing or sniffing the cookie and decoding it.

[CNNVD]PHP-Nuke Cookie脆弱加密机制漏洞(CNNVD-200111-026)

        CVE(CAN) ID: CAN-2001-0911
        这是由于PHP Nuke把用户帐号密码信息进行base64编码后存储在客户端Cookie中,而该

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20011121 PhpNuke Admin password can be stolen !
(VENDOR_ADVISORY)  XF  phpnuke-postnuke-insecure-passwords(7596)

- 漏洞信息

PHP-Nuke Cookie脆弱加密机制漏洞
高危 输入验证
2001-11-21 00:00:00 2006-09-25 00:00:00
        CVE(CAN) ID: CAN-2001-0911
        这是由于PHP Nuke把用户帐号密码信息进行base64编码后存储在客户端Cookie中,而该

- 公告与补丁

        * 退出登陆后删除Cookie


- 漏洞信息

PostNuke/PHP-Nuke Weak Password Encryption

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-11-21 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHP Nuke Weak Encryption In User Cookie Vulnerability
Design Error 3567
Yes No
2001-11-22 12:00:00 2009-07-11 09:06:00
Posted by Cabezon Aurélien <> to the BugTraq mailing list on November 22, 2001.

- 受影响的程序版本

PostNuke Development Team PostNuke 0.64
- Apache Software Foundation Apache 1.3.20
- Apache Software Foundation Apache 1.3.20
Francisco Burzi PHP-Nuke 5.3.1
Francisco Burzi PHP-Nuke 5.2
Francisco Burzi PHP-Nuke 5.1

- 漏洞讨论

PHP-Nuke is a popular web based Portal system. It allows users to create accounts and contribute content to the site.

When a user authenticates to a PHP-Nuke based page, a cookie is created which includes that user's account name and password. This password is encoded using Base 64 encoding, and can be immediately decoded by anyone with access to the cookies contents. This, an attacker able to gain access to this cookie may trivially learn the user's account name and password, and compromise that account.

Older versions of PHP-Nuke may also be vulnerable. PostNuke 0.6.4(and possibly earlier versions) is also vulnerable.

- 漏洞利用

No exploit is required.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考