发布时间 :2001-12-21 00:00:00
修订时间 :2016-10-17 22:12:40

[原文]OpenSSH 3.0.1 and earlier with UseLogin enabled does not properly cleanse critical environment variables such as LD_PRELOAD, which allows local users to gain root privileges.

[CNNVD]OpenSSH UseLogin环境变量传递漏洞(CNNVD-200112-123)

        OpenSSH 3.0.1及其早期版本存在漏洞。当UseLogin有效时,该软件不能正确的净化关键环境变量如:D_PRELOAD,本地用户利用该漏洞提升根特权。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:redhat:linux:7.1Red Hat Linux 7.1
cpe:/a:openbsd:openssh:3.0.1OpenBSD OpenSSH 3.0.1
cpe:/o:suse:suse_linux:7.1SuSE SuSE Linux 7.1
cpe:/o:suse:suse_linux:7.2SuSE SuSE Linux 7.2
cpe:/o:suse:suse_linux:7.0SuSE SuSE Linux 7.0
cpe:/o:redhat:linux:7.2Red Hat Linux 7.2
cpe:/o:redhat:linux:7.0Red Hat Linux 7.0
cpe:/o:suse:suse_linux:6.4SuSE SuSE Linux 6.4
cpe:/o:suse:suse_linux:7.3SuSE SuSE Linux 7.3

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20011204 [Fwd: OpenSSH 3.0.2 fixes UseLogin vulnerability]
(UNKNOWN)  BID  3614
(UNKNOWN)  XF  openssh-uselogin-execute-code(7647)

- 漏洞信息

OpenSSH UseLogin环境变量传递漏洞
高危 输入验证
2001-12-21 00:00:00 2006-03-28 00:00:00
        OpenSSH 3.0.1及其早期版本存在漏洞。当UseLogin有效时,该软件不能正确的净化关键环境变量如:D_PRELOAD,本地用户利用该漏洞提升根特权。

- 公告与补丁

        Update available:
        OpenBSD OpenSSH 1.2.3
        OpenBSD OpenSSH 2.1.1 p1
        OpenBSD OpenSSH 2.9 p2

- 漏洞信息

OpenSSH UseLogin Environment Variable Local Command Execution
Local Access Required Input Manipulation, Misconfiguration
Loss of Confidentiality, Loss of Integrity, Loss of Availability Upgrade
Exploit Public Vendor Verified

- 漏洞描述

OpenSSH contains a flaw that may allow a malicious local attacker to execute arbitrary code on the system. The issue is triggered by a vulnerability in the UseLogin configuration option. If the UseLogin option is enabled, a local attacker can set the LD_PRELOAD or LD_LIBRARY_PATH environment variable to point to a maliciously created shared library file, which would be executed with superuser privileges when the login program is executed. This flaw may lead to a loss of Confidentiality, Integrity, and/or Availability.

- 时间线

2001-12-04 Unknow
2001-12-04 Unknow

- 解决方案

Upgrade to version 3.0.2 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by applying the vendor-supplied patch, or by disabling UseLogin in the configuration.

- 相关参考

- 漏洞作者

Unknown or Incomplete