CVE-2001-0850
CVSS10.0
发布时间 :2001-12-06 00:00:00
修订时间 :2008-09-05 16:25:04
NMCO    

[原文]A configuration error in the libdb1 package in OpenLinux 3.1 uses insecure versions of the snprintf and vsnprintf functions, which could allow local or remote users to exploit those functions with a buffer overflow.


[CNNVD]OpenLinux漏洞(CNNVD-200112-015)

        OpenLinux 3.1版本的libdb1数据包存在配置错误漏洞,该版本使用不安全版本的snprintf和vsnprintf函数。本地或者远程用户借助该漏洞使用有缓冲区溢出的函数。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0850
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0850
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-015
(官方数据源) CNNVD

- 其它链接及资源

http://www.caldera.com/support/security/advisories/CSSA-2001-037.0.txt
(VENDOR_ADVISORY)  CALDERA  CSSA-2001-037.0
http://xforce.iss.net/static/7427.php
(UNKNOWN)  XF  openlinux-libdb-bo(7427)

- 漏洞信息

OpenLinux漏洞
危急 缓冲区溢出
2001-12-06 00:00:00 2005-05-02 00:00:00
远程  
        OpenLinux 3.1版本的libdb1数据包存在配置错误漏洞,该版本使用不安全版本的snprintf和vsnprintf函数。本地或者远程用户借助该漏洞使用有缓冲区溢出的函数。

- 公告与补丁

        

- 漏洞信息

5535
OpenLinux libdb1 Insecure Functions

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-04-08 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站