CVE-2001-0828
CVSS5.1
发布时间 :2001-12-06 00:00:00
修订时间 :2008-09-10 15:09:02
NMCO    

[原文]A cross-site scripting vulnerability in Caucho Technology Resin before 1.2.4 allows a malicious webmaster to embed Javascript in a hyperlink that ends in a .jsp extension, which causes an error message that does not properly quote the Javascript.


[CNNVD]Caucho Technology Resin脚本嵌入漏洞(CNNVD-200112-039)

        Caucho Technology Resin 1.2.4之前的版本存在跨站脚本攻击漏洞。恶意网络管理员可以将Javascript嵌入到以.jsp扩展名结尾的超链接中,该漏洞可以导致一个不正确引用Javascript的错误消息。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:caucho_technology:resin:1.2.2
cpe:/a:caucho_technology:resin:1.2.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0828
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0828
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-039
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/981651
(UNKNOWN)  CERT-VN  VU#981651
http://www.securityfocus.com/bid/2981
(VENDOR_ADVISORY)  BID  2981
http://www.caucho.com/products/resin/changes.xtp
(VENDOR_ADVISORY)  CONFIRM  http://www.caucho.com/products/resin/changes.xtp
http://xforce.iss.net/xforce/xfdb/6793
(UNKNOWN)  XF  java-servlet-crosssite-scripting(6793)
http://www.osvdb.org/1890
(UNKNOWN)  OSVDB  1890
http://archive.cert.uni-stuttgart.de/archive/bugtraq/2001/07/msg00021.html
(UNKNOWN)  BUGTRAQ  20010702 Multiple Vendor Java Servlet Container Cross-Site Scripting Vulnerability

- 漏洞信息

Caucho Technology Resin脚本嵌入漏洞
中危 跨站脚本
2001-12-06 00:00:00 2005-05-02 00:00:00
远程  
        Caucho Technology Resin 1.2.4之前的版本存在跨站脚本攻击漏洞。恶意网络管理员可以将Javascript嵌入到以.jsp扩展名结尾的超链接中,该漏洞可以导致一个不正确引用Javascript的错误消息。

- 公告与补丁

        

- 漏洞信息

1890
Caucho Resin Java Servlet Error Page XSS
Remote / Network Access Input Manipulation
Loss of Integrity Workaround, Upgrade
Exploit Public Vendor Verified, Third-party Verified

- 漏洞描述

Resin contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user input upon submission to the Java Servlet which is in turn passed to the error handler. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2001-07-02 Unknow
2001-07-02 2001-04-11

- 解决方案

Upgrade to version 1.2.4 or higher, as it has been reported to fix this vulnerability. It is also possible to temporarily work around the flaw by implementing the following workaround: Customize error pages.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站