CVE-2001-0824
CVSS7.5
发布时间 :2001-12-06 00:00:00
修订时间 :2008-09-10 15:09:01
NMCOS    

[原文]Cross-site scripting vulnerability in IBM WebSphere 3.02 and 3.5 FP2 allows remote attackers to execute Javascript by inserting the Javascript into (1) a request for a .JSP file, or (2) a request to the webapp/examples/ directory, which inserts the Javascript into an error page.


[CNNVD]IBM WebSphere跨站脚本攻击(XSS)漏洞(CNNVD-200112-066)

        IBM WebSphere 3.02和3.5 FP2存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过向(1).JSP文件的请求,或(2)webapp/examples/目录的请求插入Javascript执行Javascript,该漏洞可以向错误页面插入Javascript。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ibm:websphere_application_server:3.5IBM WebSphere Application Server 3.5
cpe:/a:ibm:websphere_application_server:3.0.2IBM WebSphere Application Server 3.0.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0824
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0824
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-066
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2969
(VENDOR_ADVISORY)  BID  2969
http://archive.cert.uni-stuttgart.de/archive/bugtraq/2001/07/msg00021.html
(UNKNOWN)  BUGTRAQ  20010702 Multiple Vendor Java Servlet Container Cross-Site Scripting Vulnerability

- 漏洞信息

IBM WebSphere跨站脚本攻击(XSS)漏洞
高危 跨站脚本
2001-12-06 00:00:00 2005-10-20 00:00:00
远程  
        IBM WebSphere 3.02和3.5 FP2存在跨站脚本攻击(XSS)漏洞。远程攻击者可以通过向(1).JSP文件的请求,或(2)webapp/examples/目录的请求插入Javascript执行Javascript,该漏洞可以向错误页面插入Javascript。

- 公告与补丁

        The vendor has provided fix for this issue.
        IBM Websphere Application Server 3.0.2
        
        IBM Websphere Application Server 3.5
        

- 漏洞信息

15790
IBM WebSphere Application Server (WAS) Error Page XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-21 Unknow
2005-04-21 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

- 漏洞信息

IBM WebSphere Cross-Site Scripting Vulnerability
Input Validation Error 2969
Yes No
2001-07-02 12:00:00 2009-07-11 06:56:00
This vulnerability was submitted to BugTraq by "TAKAGI, Hiromitsu" <takagi@etl.go.jp> on July 2nd, 2001.

- 受影响的程序版本

IBM Websphere Application Server 3.5
IBM Websphere Application Server 3.0.2
- IBM AIX 4.3
- Linux kernel 2.3 .x
- Microsoft Windows NT 4.0
- Sun Solaris 8_sparc

- 漏洞讨论

IBM WebSphere is a series of commercial webserver and webserver related products.

IBM WebSphere does not filter script embedding from user-submitted links that are displayed on the server's websites. A malicious webmaster can exploit this vulnerability to cause JavaScript commands or embedded scripts to be executed by any user who clicks on the hyper-link.

When the malicious hyper-link is clicked it will produce the standard error message for the webserver, but it will also run the arbitrary code in the same browser as the domain.

- 漏洞利用

"TAKAGI, Hiromitsu" provided these examples in his BugTraq posting:

WebSphere 3.5 FP2:
http://WebSphere/webapp/examples/&lt;SCRIPT&gt;alert(document.cookie)&lt;/SCRIPT&gt;
WebSphere 3.02:
http://WebSphere/&lt;SCRIPT&gt;alert(document.cookie)&lt;/SCRIPT&gt;.jsp

- 解决方案

The vendor has provided fix for this issue.


IBM Websphere Application Server 3.0.2

IBM Websphere Application Server 3.5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站