CVE-2001-0817
CVSS10.0
发布时间 :2001-12-06 00:00:00
修订时间 :2008-09-05 16:24:59
NMCOS    

[原文]Vulnerability in HP-UX line printer daemon (rlpdaemon) in HP-UX 10.01 through 11.11 allows remote attackers to modify arbitrary files and gain root privileges via a certain print request.


[CNNVD]HP-UX远程行式打印机后台程序逻辑缺陷漏洞(CNNVD-200112-053)

        HP-UX 10.01到11.11版本的HP-UX line printer daemon (rlpdaemon)存在漏洞。远程攻击者可以借助某个打印请求修改任意文件并获取根权限。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:hp:hp-ux:11.00HP-UX 11.00
cpe:/o:hp:hp-ux:10.10HP HP-UX 10.10
cpe:/o:hp:hp-ux:10.20HP HP-UX 10.20
cpe:/o:hp:hp-ux:11.11HP-UX 11.11
cpe:/o:hp:hp-ux:10.01HP HP-UX 10.01

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0817
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0817
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200112-053
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/638011
(UNKNOWN)  CERT-VN  VU#638011
http://www.cert.org/advisories/CA-2001-32.html
(UNKNOWN)  CERT  CA-2001-32
http://xforce.iss.net/static/7234.php
(VENDOR_ADVISORY)  XF  hpux-rlpdaemon-logic-flaw(7234)
http://xforce.iss.net/alerts/advise102.php
(VENDOR_ADVISORY)  ISS  20011120 Remote Logic Flaw Vulnerability in HP-UX Line Printer Daemon
http://archives.neohapsis.com/archives/hp/2001-q4/0047.html
(VENDOR_ADVISORY)  HP  HPSBUX0111-176
http://www.securityfocus.com/bid/3561
(UNKNOWN)  BID  3561
http://www.ciac.org/ciac/bulletins/m-021.shtml
(UNKNOWN)  CIAC  M-021

- 漏洞信息

HP-UX远程行式打印机后台程序逻辑缺陷漏洞
危急 边界条件错误
2001-12-06 00:00:00 2005-10-20 00:00:00
远程  
        HP-UX 10.01到11.11版本的HP-UX line printer daemon (rlpdaemon)存在漏洞。远程攻击者可以借助某个打印请求修改任意文件并获取根权限。

- 公告与补丁

        The following patches are available:
        HP HP-UX 10.0 1
        
        HP HP-UX 10.10
        
        HP HP-UX 10.20
        
        HP HP-UX 11.0
        
        HP HP-UX 11.11
        

- 漏洞信息

9618
HP-UX rlpdaemon Print Request Arbitrary Command Execution
Remote / Network Access Misconfiguration
Loss of Integrity
Exploit Unknown

- 漏洞描述

HP-UX rlpdaemon contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is due to a logic flaw in rlpdaemon. By sending a specially crafted print request to write arbitrary files or create directories on the target system, a remote attacker can gain local access and elevate their privileges. This flaw may lead to a loss of Integrity.

- 时间线

2001-11-20 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Hewlett-Packard has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

HP-UX Remote Line Printer Daemon Logic Flaw Vulnerability
Boundary Condition Error 3561
Yes No
2001-11-20 12:00:00 2009-07-11 09:06:00
This vulnerability was published in an Internet Security Systems Security Advisory on November 20th, 2001.

- 受影响的程序版本

HP HP-UX 11.11
HP HP-UX 11.0
HP HP-UX 10.20
HP HP-UX 10.10
HP HP-UX 10.0 1

- 漏洞讨论

Rlpdaemon is the line printer daemon that ships with HP-UX. It is intended to provide print-sharing capabilities over a network. It is installed by default on HP-UX systems and runs as superuser. Rlpdaemon is based on the original BSD Unix line printer daemon and is similar to the lpd incorporated into other Unix variants.

The HP-UX line printer daemon is prone to an issue which may allow a remote attacker to gain local access to a host running the vulnerable package.

This vulnerability may allow a remote attacker to make a specially crafted print request which is able to write to arbitrary files or create directories on the host.

This may result in the remote attacker gaining local access, potentially with elevated privileges.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

The following patches are available:


HP HP-UX 10.0 1

HP HP-UX 10.10

HP HP-UX 10.20

HP HP-UX 11.0

HP HP-UX 11.11

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站