CVE-2001-0780
CVSS5.0
发布时间 :2001-10-18 00:00:00
修订时间 :2016-05-25 13:38:18
NMCOES    

[原文]Directory traversal vulnerability in cosmicpro.cgi in Cosmicperl Directory Pro 2.0 allows remote attackers to gain sensitive information via a .. (dot dot) in the SHOW parameter.


[CNNVD]Directory Pro 泄露文件内容漏洞(CNNVD-200110-101)

        CVE(CAN) ID: CAN-2001-0780
        
        
        
        Webdirectory Pro 是 Cosmicperl 开发的web 应用程序。它是一个 CGI 脚本,脚本名为directorypro.cgi。
        
        
        
        Webdirectory Pro 对用户输入没有作很好的检查,存有漏洞。这使得敏感信息可能会泄露给攻击者。问题的原因是该脚本对 show变量没有作合适的检查,对用户输入数据中的 NULL 字节缺乏检查。结果是可以输出任何 web 服务器可读的文件的内容。
        
        
        
        <* 来源:Marshal (marshal@marshal-soft.com) *>
        
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CWE (弱点类目)

CWE-22 [对路径名的限制不恰当(路径遍历)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0780
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0780
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200110-101
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2793
(VENDOR_ADVISORY)  BID  2793
http://www.securityfocus.com/archive/1/187182
(VENDOR_ADVISORY)  BUGTRAQ  20010527 directorypro.cgi , directory traversal

- 漏洞信息

Directory Pro 泄露文件内容漏洞
中危 输入验证
2001-10-18 00:00:00 2005-10-20 00:00:00
远程  
        CVE(CAN) ID: CAN-2001-0780
        
        
        
        Webdirectory Pro 是 Cosmicperl 开发的web 应用程序。它是一个 CGI 脚本,脚本名为directorypro.cgi。
        
        
        
        Webdirectory Pro 对用户输入没有作很好的检查,存有漏洞。这使得敏感信息可能会泄露给攻击者。问题的原因是该脚本对 show变量没有作合适的检查,对用户输入数据中的 NULL 字节缺乏检查。结果是可以输出任何 web 服务器可读的文件的内容。
        
        
        
        <* 来源:Marshal (marshal@marshal-soft.com) *>
        
        

- 公告与补丁

        
        
        临时解决方法:
        
        
        
         CNNVD建议您采用适当的方法对 web 请求进行 过滤,滤去诸如 "../"、%00 之类的字符。
        
        
        
        厂商补丁:
        
        
        
        目前厂商还没有提供补丁或者升级程序。我们建议使用此软件的用户随时关注厂商站点以获取最新版本:
        
        
        http://www.cosmicflame.com/scripts/dirpro.shtml

        
        
        

- 漏洞信息 (20887)

Cosmicperl Directory Pro 2.0 Arbitrary File Disclosure Vulnerability (EDBID:20887)
cgi remote
2001-05-28 Verified
0 Marshal
N/A [点击下载]
source: http://www.securityfocus.com/bid/2793/info

Webdirectory Pro is a web application used to create a searchable directory of links developed by Cosmicperl.

Webdirectory Pro contains an input validation vulnerability which may lead to disclosure of sensitive information to attackers. The value of the 'show' variable is not properly validated and can be used to force 'directorypro.cgi' to output the contents of an arbitrary webserver-readable file to a remote attacker.

This is due to a lack of checks for NULL bytes in user-supplied data. 

Submit a request such as this to a vulnerable webserver:

http://target/cgi-bin/directorypro.cgi?want=showcat&show=../../../..//etc/motd%00

This will result in the contents of '/etc/motd' being output.

		

- 漏洞信息

563
Cosmicperl Directory Pro directorypro.cgi show Parameter Traversal Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality

- 漏洞描述

- 时间线

2001-05-27 Unknow
2001-05-27 Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Directory Pro Arbitrary File Disclosure Vulnerability
Input Validation Error 2793
Yes No
2001-05-28 12:00:00 2009-07-11 06:06:00
Discovered by Marshal <marshal@marshal-soft.com> and published on May 28, 2001.

- 受影响的程序版本

Cosmicperl Directory Pro 2.0

- 漏洞讨论

Webdirectory Pro is a web application used to create a searchable directory of links developed by Cosmicperl.

Webdirectory Pro contains an input validation vulnerability which may lead to disclosure of sensitive information to attackers. The value of the 'show' variable is not properly validated and can be used to force 'directorypro.cgi' to output the contents of an arbitrary webserver-readable file to a remote attacker.

This is due to a lack of checks for NULL bytes in user-supplied data.

- 漏洞利用

Submit a request such as this to a vulnerable webserver:

http://target/cgi-bin/directorypro.cgi?want=showcat&amp;show=../../../..//etc/motd%00

This will result in the contents of '/etc/motd' being output.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站