发布时间 :2001-12-06 00:00:00
修订时间 :2016-10-17 22:11:50

[原文]Internet Explorer 5.5 and 6.0 allows remote attackers to read and modify user cookies via Javascript in an about: URL, aka the "First Cookie Handling Vulnerability."

[CNNVD]Microsoft IE Cookie 信息泄露/修改漏洞(MS01-055)(CNNVD-200112-041)

        CVE(CAN) ID: CVE-2001-0722
        CVE ID:CAN-2001-0722
        Microsoft Internet Explorer 存在一个安全漏洞,通过精心构造一个URL请求,可能

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:microsoft:ie:6.0Microsoft Internet Explorer 6.0
cpe:/a:microsoft:ie:5.5Microsoft ie 5.5

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20011108 Microsoft IE cookies readable via about: URLS
(VENDOR_ADVISORY)  BUGTRAQ  20011019 Minor IE vulnerability: about: URLs
(UNKNOWN)  BID  3513
(UNKNOWN)  XF  ie-about-cookie-information(7486)

- 漏洞信息

Microsoft IE Cookie 信息泄露/修改漏洞(MS01-055)
中危 访问验证错误
2001-12-06 00:00:00 2005-10-12 00:00:00
        CVE(CAN) ID: CVE-2001-0722
        CVE ID:CAN-2001-0722
        Microsoft Internet Explorer 存在一个安全漏洞,通过精心构造一个URL请求,可能

- 公告与补丁

        * 在IE中禁止"Active Scripting"
        * 在Outlook中安装"Outlook Email Security Update"或配置为在"Restricted


- 漏洞信息 (21144)

Microsoft Internet Explorer 5/6 Cookie Disclosure/Modification Vulnerability (EDBID:21144)
windows remote
2001-11-09 Verified
0 Jouko Pynnonen
N/A [点击下载]

Internet Explorer contains a vulnerability, which could allow an attacker to construct a URL that would display or modify the cookie information associated with an arbitrary website.

If a URL is composed in the about: protocol referencing a website, Javascript embedded in the URL can access any cookies associated with that website via 'document.cookie'. The Javascript executes because of a cross-site scripting condition in the about: protocol. 

about://<script language=javascript>alert(document.cookie);</script> 		

- 漏洞信息

Microsoft IE about: URI XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality
Exploit Public

- 漏洞描述

Microsoft IE contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate about: URIs. This may allow a user to create a specially crafted request that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2001-11-08 Unknow
2001-11-08 Unknow

- 解决方案

Microsoft has released a patch to address this issue. Additionally, it is possible to correct the flaw by implementing the following workaround(s): Disable active scripting

- 相关参考

- 漏洞作者