CVE-2001-0670
CVSS7.5
发布时间 :2001-10-03 00:00:00
修订时间 :2008-09-05 16:24:39
NMCO    

[原文]Buffer overflow in BSD line printer daemon (in.lpd or lpd) in various BSD-based operating systems allows remote attackers to execute arbitrary code via an incomplete print job followed by a request to display the printer queue.


[CNNVD]Multiple BSD Vendor lpd 缓冲区溢出漏洞(CNNVD-200110-020)

        多种BSD-based操作系统的printer daemon (in.lpd or lpd)的BSD存在缓冲区溢出漏洞。远程攻击者可以借助带有显示打印队列请求的不完整打印工作执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:freebsd:freebsd:4.3FreeBSD 4.3
cpe:/o:bsd:bsd:4.1
cpe:/o:netbsd:netbsd:1.5.1NetBSD 1.5.1
cpe:/o:openbsd:openbsdOpenBSD

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0670
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0670
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200110-020
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/274043
(UNKNOWN)  CERT-VN  VU#274043
http://www.cert.org/advisories/CA-2001-30.html
(UNKNOWN)  CERT  CA-2001-30
http://xforce.iss.net/alerts/advise94.php
(VENDOR_ADVISORY)  ISS  20010829 Remote Buffer Overflow Vulnerability in BSD Line Printer Daemon
http://www.openbsd.com/errata28.html
(PATCH)  OPENBSD  20010829
ftp://stage.caldera.com/pub/security/openserver/CSSA-2001-SCO.20/CSSA-2001-SCO.20.txt
(PATCH)  CALDERA  CSSA-2001-SCO.20
http://xforce.iss.net/static/7046.php
(UNKNOWN)  XF  bsd-lpd-bo(7046)
http://www.securityfocus.com/bid/3252
(UNKNOWN)  BID  3252
http://www.redhat.com/support/errata/RHSA-2001-147.html
(UNKNOWN)  REDHAT  RHSA-2001:147
ftp://ftp.netbsd.org/pub/NetBSD/security/advisories/NetBSD-SA2001-018.txt.asc
(UNKNOWN)  NETBSD  NetBSD-SA2001-018

- 漏洞信息

Multiple BSD Vendor lpd 缓冲区溢出漏洞
高危 缓冲区溢出
2001-10-03 00:00:00 2005-05-02 00:00:00
远程  
        多种BSD-based操作系统的printer daemon (in.lpd or lpd)的BSD存在缓冲区溢出漏洞。远程攻击者可以借助带有显示打印队列请求的不完整打印工作执行任意代码。

- 公告与补丁

        WindRiver has released a fix for BSD/OS version 4.1.
        Patches will be available from other affected vendors soon.
        Security Focus recommends disabling the service or blocking outside access to it immediately. This may be accomplished by terminating the processes/disabling the service on the affected hosts or implementing strict network access controls limiting access to the service.
        Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .
        
        
        FreeBSD FreeBSD 3.0
        
        FreeBSD FreeBSD 3.1
        
        FreeBSD FreeBSD 3.2
        
        FreeBSD FreeBSD 3.3
        
        FreeBSD FreeBSD 3.4
        
        FreeBSD FreeBSD 3.5
        
        FreeBSD FreeBSD 3.5.1
        
        FreeBSD FreeBSD 4.0
        
        BSDI BSD/OS 4.1
        
        FreeBSD FreeBSD 4.1
        
        FreeBSD FreeBSD 4.1.1
        
        FreeBSD FreeBSD 4.2
        
        SCO Open Server 5.0.1
        
        SCO Open Server 5.0.2
        
        SCO Open Server 5.0.3
        
        SCO Open Server 5.0.4
        
        SCO Open Server 5.0.5
        
        SCO Open Server 5.0.6 a
        
        SCO Open Server 5.0.6
        
        S.u.S.E. Linux 6.3
        
        S.u.S.E. Linux 6.3 alpha
        
        S.u.S.E. Linux 6.4 ppc
        
        S.u.S.E. Linux 6.4 alpha
        
        S.u.S.E. Linux 6.4
        
        S.u.S.E. Linux 7.0 ppc
        
        S.u.S.E. Linux 7.0
        
        S.u.S.E. Linux 7.0 sparc
        

- 漏洞信息

1945
Multiple Unix Vendor lpd Incomplete Print Job Display Queue Overflow
Local Access Required Input Manipulation
Loss of Integrity

- 漏洞描述

A local overflow exists in multiple operating systems. The line printer daemon (lpd) fails to correctly parse an incomplete print job request, resulting in a buffer overflow. With a specially crafted request, an attacker can execute arbitrary code resulting in a loss of integrity.

- 时间线

2001-08-29 Unknow
Unknow Unknow

- 解决方案

Upgrade to FreeBSD version 4.3-STABLE or to the RELENG_4_3 security branch after the respective correction date or higher, as it has been reported to fix this vulnerability. In addition, FreeBSD has released patches for some older versions. It is also possible to correct the flaw by implementing the following workaround: killall lpd. Upgrade to NetBSD version 1.5.2 after the respective correction date or higher, as it has been reported to fix this vulnerability. In addition, NetBSD has released patches for some older versions. It is also possible to correct the flaw by implementing the following workaround: killall lpd and/or edit /etc/hosts.lpd to prevent remote connections to lpd. OpenBSD has released a patch for some older versions. Caldera/SCO has released patches for some older versions. IBM has released a patch for some older versions. Redhat has released patches for some older versions. SuSE has released patches for some older versions.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站