发布时间 :2001-08-22 00:00:00
修订时间 :2017-12-18 21:29:24

[原文]Carello E-Commerce 1.2.1 and earlier allows a remote attacker to gain additional privileges and execute arbitrary commands via a specially constructed URL.

[CNNVD]Carello E-Commerce权限许可和访问控制漏洞(CNNVD-200108-130)

        Carello E-Commerce 1.2.1及其早期版本存在漏洞。远程攻击者可以借助特定结构URL提升额外特权并执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20010514 def-2001-25: Carello E-Commerce Arbitrary Command Execution
(UNKNOWN)  XF  carello-url-code-execution(6532)

- 漏洞信息

Carello E-Commerce权限许可和访问控制漏洞
高危 未知
2001-08-22 00:00:00 2005-10-20 00:00:00
        Carello E-Commerce 1.2.1及其早期版本存在漏洞。远程攻击者可以借助特定结构URL提升额外特权并执行任意命令。

- 公告与补丁


- 漏洞信息 (20850)

Pacific Software Carello 1.2.1 Shopping Cart Command Execution Vulnerability (EDBID:20850)
windows remote
2001-05-14 Verified
0 Peter Gründl
N/A [点击下载]

It is possible for a remote user to execute arbitrary commands on a host using Carello Shopping Cart software. A specially crafted HTTP request could cause inetinfo.exe to consume all available system resources, refusing any new connections. If arbitrary code is part of the HTTP request, it will be executed with the privileges of the web server.\..\winnt\system32\cmd.exe20/c20echo20test>c:\defcom.txt 		

- 漏洞信息

Carello E-Commerce Carello.dll URL Request Parsing Remote Command Execution
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability Upgrade
Exploit Public Third-party Verified

- 漏洞描述

Carello contains a flaw that may allow a malicious user to execute arbitrary code or cause a denial of service. The issue is triggered when a specially crafted HTTP request is sent to the Carello.dll library. It is possible that the flaw may allow arbitrary code execution resulting in a loss of integrity.

- 时间线

2001-05-14 2001-04-03
2001-05-14 Unknow

- 解决方案

Upgrade to version 1.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者