CVE-2001-0560
CVSS4.6
发布时间 :2001-08-22 00:00:00
修订时间 :2008-09-05 16:24:24
NMCO    

[原文]Buffer overflow in Vixie cron 3.0.1-56 and earlier could allow a local attacker to gain additional privileges via a long username (> 20 characters).


[CNNVD]Vixie cron缓冲区溢出漏洞(CNNVD-200108-106)

        Vixie cron 3.0.1-56及其早期版本存在缓冲区溢出漏洞。本地用户可以借助超长用户名(> 20个字符)提升额外特权。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0560
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0560
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200108-106
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/6098.php
(VENDOR_ADVISORY)  XF  vixie-crontab-bo(6098)
http://www.redhat.com/support/errata/RHSA-2001-014.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2001:014
http://www.linux-mandrake.com/en/security/2001/MDKSA-2001-022.php3
(VENDOR_ADVISORY)  MANDRAKE  MDKSA-2001:022
http://archives.neohapsis.com/archives/linux/immunix/2001-q1/0066.html
(VENDOR_ADVISORY)  BUGTRAQ  20010220 Immunix OS Security update for vixie-cron
http://archives.neohapsis.com/archives/bugtraq/2001-02/0197.html
(VENDOR_ADVISORY)  BUGTRAQ  20010210 vixie cron possible local root compromise
http://www.osvdb.org/5583
(UNKNOWN)  OSVDB  5583
http://www-1.ibm.com/support/search.wss?rs=0&q=IY17261&apar=only
(UNKNOWN)  AIXAPAR  IY17261
http://www-1.ibm.com/support/search.wss?rs=0&q=IY17048&apar=only
(UNKNOWN)  AIXAPAR  IY17048

- 漏洞信息

Vixie cron缓冲区溢出漏洞
中危 缓冲区溢出
2001-08-22 00:00:00 2006-08-30 00:00:00
本地  
        Vixie cron 3.0.1-56及其早期版本存在缓冲区溢出漏洞。本地用户可以借助超长用户名(> 20个字符)提升额外特权。

- 公告与补丁

        

- 漏洞信息

5583
Vixie Cron Long Username Overflow
Local Access Required Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Unknown

- 漏洞描述

A local overflow exists in Vixie cron. The software fails to do proper bounds checking on the username resulting in a buffer overflow in the strcpy() function. With a specially crafted request, an attacker can cause a Denial of Service of the cron daemon resulting in a loss of availability.

- 时间线

2001-02-10 2001-02-10
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, vendors have released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站