CVE-2001-0553
CVSS7.2
发布时间 :2001-08-14 00:00:00
修订时间 :2008-09-05 16:24:23
NMCOE    

[原文]SSH Secure Shell 3.0.0 on Unix systems does not properly perform password authentication to the sshd2 daemon, which allows local users to gain access to accounts with short password fields, such as locked accounts that use "NP" in the password field.


[CNNVD]SSH短密码登陆漏洞(CNNVD-200108-075)

        Unix系统的SSH Secure Shell 3.0.0版本不能正确地对sshd2守护程序执行密码认证,本地用户可以获得带有短密码字段的账号的使用权,例如在密码字段中使用"NP"的锁定账户。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0553
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0553
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200108-075
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/737451
(UNKNOWN)  CERT-VN  VU#737451
http://archives.neohapsis.com/archives/bugtraq/2001-07/0486.html
(VENDOR_ADVISORY)  BUGTRAQ  20010720 URGENT SECURITY ADVISORY FOR SSH SECURE SHELL 3.0.0
http://www.ssh.com/products/ssh/exploit.cfm
(UNKNOWN)  CONFIRM  http://www.ssh.com/products/ssh/exploit.cfm
http://xforce.iss.net/xforce/xfdb/6868
(UNKNOWN)  XF  ssh-password-length-unauth-access(6868)
http://www.securityfocus.com/bid/3078
(UNKNOWN)  BID  3078
http://www.osvdb.org/586
(UNKNOWN)  OSVDB  586
http://www.ciac.org/ciac/bulletins/l-121.shtml
(UNKNOWN)  CIAC  L-121

- 漏洞信息

SSH短密码登陆漏洞
高危 输入验证
2001-08-14 00:00:00 2006-08-23 00:00:00
远程  
        Unix系统的SSH Secure Shell 3.0.0版本不能正确地对sshd2守护程序执行密码认证,本地用户可以获得带有短密码字段的账号的使用权,例如在密码字段中使用"NP"的锁定账户。

- 公告与补丁

        A vendor-supplied update that rectifies this issue is available:
        SSH Communications Security SSH2 3.0
        

- 漏洞信息 (21021)

SSH2 3.0 Short Password Login Vulnerability (EDBID:21021)
unix remote
2001-07-21 Verified
0 hypoclear
N/A [点击下载]
source: http://www.securityfocus.com/bid/3078/info

An input validation error exists in version 3.0.0 of the SSH daemon (sshd) running on Unix platforms.

It may be possible for remote users to log in to accounts for which there are two or less characters in the password field of the system password file. Due to the nature of the problem, it may be possible to log in to a vulnerable system using such an account with any password. This may lead to further system compromise. 

#!/usr/bin/perl
#
# A local SSH 3.0.0 vulnerability scanner for the 
# SSH Short Password Login Vulnerability, BugtraqID: 3078
#
# Note: You must have superuser access on the system to scan it.
#
# usage: ./ssh3.pl <host>
#        Optional: -e turn off error
#                  -h specify a different /etc/shadow file
# (Options must come before host name)
# 
# Written by hypoclear hypoclear@jungle.net - http://hypoclear.cjb.net
#
# This and all of my programs fall under my disclaimer, which
# can be found at: http://hypoclear.cjb.net/hypodisclaim.txt


use IO::Socket; use Getopt::Std;
getopts('h:e');

die "\nusage: $0 <host>\n\tOptional: -e turn off error\n\t\t  -h specify a different /etc/shadow file\n\n" unless @ARGV > 0;
if (!defined $opt_h)
 { $opt_h = "/etc/shadow";
 }

$out = &bannerGrab($ARGV[0],22);
sysread $out, $message,100;
close $out;

if (($message =~ /3.0.0/) || (defined $opt_e))
 { print "Running SSH 3.0.0, checking for vulnerabilities...\n\n";
   open(SHADOW, "<$opt_h") || die "Cannot open $opt_h!\nNote: You must have superuser access to run this script.\n\n";
   while(<SHADOW>)
     { $name = $_;
       $name =~ s/:.*$//;
       $_ =~ s/^.*?\://;
       $_ =~ s/:.*$//;
       $name =~ s/\s//g; $_=~s/\s//g;
       push(@name,$name);
       push(@hash,$_);
       push(@lnnum,$cnt++); $cnt++;
     }
   close(SHADOW);

   foreach $hash (@hash)
     { @chars = split(//,$hash);
       foreach $char (@chars)
         { $count++;
         }
       if ($count <= 2)
        { print "$name[$line]\t(line $lnnum[$line]) may be vulnerable!\n";
          $vulnFlag = 1;
        }
       $count=0; $line++;
     }
   if ($vulnFlag != 1)
    { print "No accounts appear to be vulnerable.\n";
    }
 }
else
 { if (!defined $opt_e)
    { print "You are not running SSH 3.0.0.\n";
      die "If you feel that this is an error run with the -e option.\n";
    }
 }
print "\n";


sub bannerGrab
{ $host  = gethostbyname($_[0]) || warn "cannot connect to $ARGV[0]\n";
  $port  = getservbyport($_[1], 'tcp'); 
  $haddr = sockaddr_in($_[1], $host); 
  socket(OUT, PF_INET, SOCK_STREAM, getprotobyname('tcp')) || warn "$!\n"; 
  connect(OUT, $haddr) ;
  return OUT; 
}

		

- 漏洞信息

586
SSH Locked Account Remote Authentication Bypass
Local Access Required, Remote / Network Access Authentication Management, Input Manipulation, Misconfiguration
Loss of Confidentiality
Exploit Public Vendor Verified

- 漏洞描述

Ssh.com's SSH Communications software contains a flaw that may allow a malicious user to log in to any account with a short password without needing to authenticate. The issue is triggered when the account has a password that is two characters or shorter. It is possible that the flaw may allow improper logins, resulting in a loss of confidentiality.

- 时间线

2001-07-21 Unknow
2001-07-20 Unknow

- 解决方案

Upgrade to version 3.0.1 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround(s): Apply the vendor-supplied patch. Disable password authentication and use another supported form of authentication (public key, SecurID, Kerberos, certificates, Smart Cards, host-based). Limit access to the sshd2 daemon to users with entries in the /etc/passwd and /etc/shadow which exceed two characters, by using the AllowUsers, AllowGroups, DenyUsers, and DenyGroups keywords in the /etc/ssh2/sshd2_config file. Assign a valid password of more than two characters for each account. Assigning a password to some system accounts can cause problems on some operating systems, so this workaround is not recommended by the vendor. SSH Secure Shell 3.0.0 on any Unix or Linux system that uses crypt() for password encryption is vulnerable. This includes most Unix and Linux systems. SSH Secure Shell 2.3 and SSH Secure Shell 2.4 on HP-UX 10.20 and HP-UX 11.00 systems running in TCB mode are also vulerable. Any operating system that does not use the crypt() hash function for password encryption is not vulnerable.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站