CVE-2001-0551
CVSS7.2
发布时间 :2001-05-22 00:00:00
修订时间 :2009-03-04 00:08:09
NMCO    

[原文]Buffer overflow in CDE Print Viewer (dtprintinfo) allows local users to execute arbitrary code by copying text from the clipboard into the Help window.


[CNNVD]CDE dtprintinfo帮助搜索本地缓冲区溢出漏洞(CNNVD-200105-090)

        
        dtprintinfo是一款Common Desktop Environment (CDE)工具包中的工具,设计用于启动CDE打印管理窗口。
        dtprintinfo处理Help部分中的卷(volume)搜索字段存在问题,可导致本地攻击者进行缓冲区溢出攻击。
        在dtprintinfo帮助中,索引搜索功能允许以关键词进行查询,攻击者可以提交特殊构建的超长字符串给搜索参数,如把超长字符串输入到'Entries with'字段并选择单个Help卷进行搜索,可导致程序缓冲区溢出,精心构建提交的超长字符串数据可导致本地攻击者获得root权限。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:hp:hp-ux:10.24HP HP-UX 10.24
cpe:/o:hp:hp-ux:11.04HP HP-UX 11.04
cpe:/o:hp:hp-ux:11.00HP-UX 11.00
cpe:/o:hp:hp-ux:10.10HP HP-UX 10.10
cpe:/o:hp:hp-ux:10.20HP HP-UX 10.20
cpe:/o:hp:hp-ux:11.11HP-UX 11.11

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:5958HP-UX running CDE, Local Increased Privilege, Denial of Service (DoS)
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0551
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0551
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200105-090
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/860296
(VENDOR_ADVISORY)  CERT-VN  VU#860296
http://archives.neohapsis.com/archives/hp/2001-q2/0044.html
(VENDOR_ADVISORY)  HP  HPSBUX0105-151

- 漏洞信息

CDE dtprintinfo帮助搜索本地缓冲区溢出漏洞
高危 未知
2001-05-22 00:00:00 2009-03-04 00:00:00
本地  
        
        dtprintinfo是一款Common Desktop Environment (CDE)工具包中的工具,设计用于启动CDE打印管理窗口。
        dtprintinfo处理Help部分中的卷(volume)搜索字段存在问题,可导致本地攻击者进行缓冲区溢出攻击。
        在dtprintinfo帮助中,索引搜索功能允许以关键词进行查询,攻击者可以提交特殊构建的超长字符串给搜索参数,如把超长字符串输入到'Entries with'字段并选择单个Help卷进行搜索,可导致程序缓冲区溢出,精心构建提交的超长字符串数据可导致本地攻击者获得root权限。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * chmod -s `which dtprintinfo`
        厂商补丁:
        CDE
        ---
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Solaris 2.4, 2.5, 2.5.1 SPARC:
        105076-04
        Solaris 2.4, 2.5, 2.5.1 x86:
        105354-04
        Solaris 2.6 SPARC:
        106242-03
        Solaris 2.6 x86:
        106243-03
        Solaris 7 SPARC:
        107178-02
        Solaris 7 x86:
        107179-02
        Solaris 8 SPARC:
        108949-04
        Solaris 8 x86:
        108950-04
        IBM AIX:
        AIX 4.3.x:
        APAR #IY21539
        AIX 5.1:
        APAR #IY20917
        Compaq:
        SSRT1-78U
        SSRT0788U
        SSRT0757U
        SSRT-541
        HP-UX:
        10.10: PHSS_23355
        10.20: PHSS_23796
        10.24: PHSS_24097
        11.00: PHSS_23797
        11.04: PHSS_24098
        11.11: PHSS_24087, PHSS_24091

- 漏洞信息

13886
CDE Print Viewer dtprintinfo Help Window Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-12-20 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站