发布时间 :2001-08-14 00:00:00
修订时间 :2008-09-10 15:08:16

[原文]Format string vulnerability in Gnu Privacy Guard (aka GnuPG or gpg) 1.05 and earlier can allow an attacker to gain privileges via format strings in the original filename that is stored in an encrypted file.


        Gnu Privacy Guard (也称为GnuPG或gpg) 1.05版本及之前版本存在格式字符串漏洞。攻击者可以借助存于加密文件内原始文件名中的格式字符串来提升特权。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gnu:privacy_guard:8.0GNU GNU Privacy Guard 8.0
cpe:/a:gnu:privacy_guard:7.2GNU GNU Privacy Guard 7.2
cpe:/a:gnu:privacy_guard:7.1GNU GNU Privacy Guard 7.1

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  gnupg-tty-format-string(6642)
(UNKNOWN)  BID  2797
(UNKNOWN)  SUSE  SuSE-SA:2001:020
(UNKNOWN)  BUGTRAQ  20010601 The GnuPG format string bug (was: TSLSA-2001-0009 - GnuPG)
(UNKNOWN)  IMMUNIX  IMNX-2001-70-023-01

- 漏洞信息

高危 格式化字符串
2001-08-14 00:00:00 2005-05-02 00:00:00
        Gnu Privacy Guard (也称为GnuPG或gpg) 1.05版本及之前版本存在格式字符串漏洞。攻击者可以借助存于加密文件内原始文件名中的格式字符串来提升特权。

- 公告与补丁

        A new version of GnuPG is available which addresses these issues:
        GNU GNU Privacy Guard 1.0.4
        GNU GNU Privacy Guard 1.0.5

- 漏洞信息 (20889)

GNU Privacy Guard 1.0.x Format String Vulnerability (EDBID:20889)
multiple remote
2001-05-29 Verified
0 fish stiqz
N/A [点击下载]

GnuPG is a popular open source public/private key encryption system.

It is possible for attackers to create an encrypted document that will exploit a format string vulnerability in the GnuPG client when the document is decrypted.

This vulnerability may lead to remote attackers gaining access to client hosts.		

- 漏洞信息

GnuPG tty_printf() Format String
Local Access Required, Remote / Network Access, Local / Remote, Context Dependent Cryptographic, Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

GnuPG contains a flaw that may allow a malicious user to execute arbitrary code in the context of a user decrypting a given file. The issue is triggered when the attacker sends the victim a GPG message with a crafted filename, exploiting a format string vulnerability in the tty_printf() function. It is possible that the flaw may allow execution of code in the context of the target user, resulting in a loss of integrity.

- 时间线

2001-05-30 Unknow
2001-05-29 Unknow

- 解决方案

Upgrade to version 1.0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者