CVE-2001-0478
CVSS7.5
发布时间 :2001-06-27 00:00:00
修订时间 :2008-09-05 16:24:12
NMCOS    

[原文]Directory traversal vulnerability in phpMyAdmin 2.2.0 and earlier versions allows remote attackers to execute arbitrary code via a .. (dot dot) in an argument to the sql.php script.


[CNNVD]PHPMyAdmin文件泄露任意命令执行漏洞(CNNVD-200106-186)

        phpMyAdmin 2.2.0及其早期版本存在目录遍历漏洞。远程攻击者借助参数的 .. (点 点)到sql.php脚本执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0478
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0478
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200106-186
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2642
(VENDOR_ADVISORY)  BID  2642
http://archives.neohapsis.com/archives/bugtraq/2001-04/0396.html
(VENDOR_ADVISORY)  BUGTRAQ  20010423 (SRPRE00001) phpMyAdmin 2.1.0 and phpPgAdmin 2.2.1

- 漏洞信息

PHPMyAdmin文件泄露任意命令执行漏洞
高危 路径遍历
2001-06-27 00:00:00 2005-10-20 00:00:00
远程  
        phpMyAdmin 2.2.0及其早期版本存在目录遍历漏洞。远程攻击者借助参数的 .. (点 点)到sql.php脚本执行任意代码。

- 公告与补丁

        Patches available:
        phpMyAdmin phpMyAdmin 2.1
        

- 漏洞信息

7727
phpMyAdmin sql.php Traversal Arbitrary File Access
Remote / Network Access Information Disclosure
Loss of Confidentiality Patch / RCS, Upgrade
Exploit Public Vendor Verified

- 漏洞描述

phpMyAdmin contains a flaw that allows a remote attacker to access arbitrary files. This flaw exists because the application does not validate the 'goto' variable upon submission to the 'sql.php' script. By sending a specially crafted request, a remote attacker could access arbitrary files resulting in a loss of confidentiality.

- 时间线

2001-07-01 Unknow
2001-07-01 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPMyAdmin File Inclusion Arbitrary Command Execution Vulnerability
Input Validation Error 2642
Yes No
2001-04-23 12:00:00 2009-07-11 06:06:00
This vulnerability was announced to Bugtraq in a Secure Reality Security Advisory posted on April 24, 2001.

- 受影响的程序版本

phpMyAdmin phpMyAdmin 2.1
- Debian Linux 2.2 sparc
- Debian Linux 2.2 sparc
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 arm
- Debian Linux 2.2 arm
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 alpha
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Debian Linux 2.2 68k
- Debian Linux 2.2 68k
- Debian Linux 2.2
- Debian Linux 2.2
- Debian Linux 2.2
- FreeBSD FreeBSD 4.2
- FreeBSD FreeBSD 4.2
- FreeBSD FreeBSD 4.2
- FreeBSD FreeBSD 3.5.1
- FreeBSD FreeBSD 3.5.1
- FreeBSD FreeBSD 3.5.1
- Mandriva Linux Mandrake 7.2
- Mandriva Linux Mandrake 7.2
- Mandriva Linux Mandrake 7.2
- Mandriva Linux Mandrake 7.1
- Mandriva Linux Mandrake 7.1
- Mandriva Linux Mandrake 7.1
- Mandriva Linux Mandrake 7.0
- Mandriva Linux Mandrake 7.0
- Mandriva Linux Mandrake 7.0
- OpenBSD OpenBSD 2.8
- OpenBSD OpenBSD 2.8
- OpenBSD OpenBSD 2.8
- OpenBSD OpenBSD 2.7
- OpenBSD OpenBSD 2.7
- OpenBSD OpenBSD 2.7
- OpenBSD OpenBSD 2.6
- OpenBSD OpenBSD 2.6
- OpenBSD OpenBSD 2.6
- Red Hat Linux 6.2
- Red Hat Linux 6.2
- Red Hat Linux 6.2
- RedHat Linux 7.0
- RedHat Linux 7.0
- RedHat Linux 7.0
- S.u.S.E. Linux 7.1
- S.u.S.E. Linux 7.0
- S.u.S.E. Linux 7.0
- S.u.S.E. Linux 7.0
- S.u.S.E. Linux 6.4
- S.u.S.E. Linux 6.4
- S.u.S.E. Linux 6.4
- Sun Solaris 8_x86
- Sun Solaris 8_x86
- Sun Solaris 8_x86
- Sun Solaris 8_sparc
- Sun Solaris 8_sparc
- Sun Solaris 8_sparc
- Sun Solaris 7.0_x86
- Sun Solaris 7.0_x86
- Sun Solaris 7.0_x86
- Sun Solaris 7.0
- Sun Solaris 7.0
- Sun Solaris 7.0
- Sun Solaris 2.6_x86
- Sun Solaris 2.6_x86
- Sun Solaris 2.6_x86
- Sun Solaris 2.6
- Sun Solaris 2.6
- Sun Solaris 2.6

- 漏洞讨论

phpMyAdmin is a freely available, open source software package maintained by the phpMyAdmin Development Team. phpMyAdmin provides a graphical interface and friendly controls to MySQL.

A problem with the software package could allow arbitrary file inclusion. Due to the insufficient validation of input by the sql.php script, it is possible to supply an include file to the sql.php script, which will result in the code in the include file being executed. A remote user with knowledge of files on the local host, or the ability to upload an include file, may specify the file to be included in execution, which could result in code supplied include file being executed.

Therefore, it is possible for a remote user to supply an include file to the sql.php script, and execute arbitrary code.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Patches available:


phpMyAdmin phpMyAdmin 2.1

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站