CVE-2001-0463
CVSS5.0
发布时间 :2001-06-27 00:00:00
修订时间 :2008-09-05 16:24:10
NMCOE    

[原文]Directory traversal vulnerability in cal_make.pl in PerlCal allows remote attackers to read arbitrary files via a .. (dot dot) in the p0 parameter.


[CNNVD]PerlCal远程目录遍历漏洞(CNNVD-200106-137)

        
        PerlCal是Acme Software开发的CGI脚本,提供基于WEB的日历功能。
        PerlCal脚本存在漏洞,没有很好检查用户输入的数据,远程攻击者可以利用"../"技术遍历WEB根目录之外的其他目录,仅受WEB服务当前所拥有用户权限的限制。通常情况下,WEB服务以nobody用户身份运行。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:acme_labs:perlcal:2.9b
cpe:/a:acme_labs:perlcal:2.9e
cpe:/a:acme_labs:perlcal:2.9
cpe:/a:acme_labs:perlcal:2.18
cpe:/a:acme_labs:perlcal:2.9c
cpe:/a:acme_labs:perlcal:2.6
cpe:/a:acme_labs:perlcal:2.9d
cpe:/a:acme_labs:perlcal:2.95
cpe:/a:acme_labs:perlcal:2.5
cpe:/a:acme_labs:perlcal:2.4
cpe:/a:acme_labs:perlcal:2.7
cpe:/a:acme_labs:perlcal:2.13
cpe:/a:acme_labs:perlcal:2.80
cpe:/a:acme_labs:perlcal:2.3
cpe:/a:acme_labs:perlcal:2.9a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0463
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0463
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200106-137
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2663
(VENDOR_ADVISORY)  BID  2663
http://archives.neohapsis.com/archives/bugtraq/2001-04/0506.html
(VENDOR_ADVISORY)  BUGTRAQ  20010427 PerlCal (CGI) show files vulnerability
http://xforce.iss.net/static/6480.php
(UNKNOWN)  XF  perlcal-calmake-directory-traversal(6480)
http://www.perlcal.com/calendar/docs/bugs.txt
(UNKNOWN)  CONFIRM  http://www.perlcal.com/calendar/docs/bugs.txt

- 漏洞信息

PerlCal远程目录遍历漏洞
中危 未知
2001-06-27 00:00:00 2006-08-03 00:00:00
远程  
        
        PerlCal是Acme Software开发的CGI脚本,提供基于WEB的日历功能。
        PerlCal脚本存在漏洞,没有很好检查用户输入的数据,远程攻击者可以利用"../"技术遍历WEB根目录之外的其他目录,仅受WEB服务当前所拥有用户权限的限制。通常情况下,WEB服务以nobody用户身份运行。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 暂时用chmod 000去除PerlCal的执行权限。
        厂商补丁:
        Acme Software
        -------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.perlcal.com/

- 漏洞信息 (20808)

PerlCal 2.x Directory Traversal Vulnerability (EDBID:20808)
cgi remote
2001-04-27 Verified
0 ThePike
N/A [点击下载]
source: http://www.securityfocus.com/bid/2663/info

PerlCal is a CGI script written by Acme Software that allows web-based calendar sharing and related functions.

A vulnerability exists in PerlCal which can allow a remote user to traverse the filesystem of a target host. This may lead to the disclosure of potentially sensitive file contents.

Files and directories can be accessed through the use of double dot '../' techniques along with a relative path to the known resource.

Disclosed content is dependant on the privilege level of the user the server is running under, typically user 'nobody'.

This attack may lead to the disclosure of sensitive information and may aid in the assistance of future attacks. 

http://www.example.com/cgi-bin/cal_make.pl?p0=../../../../../../../../../../../../etc/passwd%00

This will display the /etc/passwd (if the webserver user has
access to this file).		

- 漏洞信息

550
PerlCal cal_make.pl p0 Parameter Traversal Arbitrary File Access
Remote / Network Access Information Disclosure
Loss of Confidentiality Workaround, Upgrade
Exploit Public Vendor Verified, Third-party Verified

- 漏洞描述

- 时间线

2001-04-27 Unknow
2001-04-27 Unknow

- 解决方案

Upgrade to version 2.98 or higher, as it has been reported to fix this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站