CVE-2001-0437
CVSS5.0
发布时间 :2001-07-02 00:00:00
修订时间 :2008-09-05 16:24:06
NMCO    

[原文]upload_file.pl in DCForum 2000 1.0 allows remote attackers to upload arbitrary files without authentication by setting the az parameter to upload_file.


[CNNVD]DCForum 'AZ'字段远程命令执行漏洞(CNNVD-200107-017)

        DCForum 2000 1.0版本的upload_file.pl存在漏洞。远程攻击者通过设置upload_file的az参数上传任意没有认证的文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:dcscripts:dcforum:1.0
cpe:/a:dcscripts:dcforum_2000:1.0
cpe:/a:dcscripts:dcforum:6.0
cpe:/a:dcscripts:dcforum:5.0
cpe:/a:dcscripts:dcforum:4.0
cpe:/a:dcscripts:dcforum:2.0
cpe:/a:dcscripts:dcforum:3.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0437
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0437
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200107-017
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2611
(VENDOR_ADVISORY)  BID  2611
http://www.dcscripts.com/FAQ/sec_2001_03_31.html
(VENDOR_ADVISORY)  CONFIRM  http://www.dcscripts.com/FAQ/sec_2001_03_31.html
http://archives.neohapsis.com/archives/bugtraq/2001-04/0269.html
(VENDOR_ADVISORY)  BUGTRAQ  20010416 qDefense Advisory: DCForum allows remote read/write/execute
http://xforce.iss.net/static/6393.php
(UNKNOWN)  XF  dcforum-az-file-upload(6393)

- 漏洞信息

DCForum 'AZ'字段远程命令执行漏洞
中危 输入验证
2001-07-02 00:00:00 2005-10-20 00:00:00
远程  
        DCForum 2000 1.0版本的upload_file.pl存在漏洞。远程攻击者通过设置upload_file的az参数上传任意没有认证的文件。

- 公告与补丁

        Excerpted from Baba :
        ---
        Apparently the DCForum bug was discovered in an internal security audit, and patches were sent out to all licensed users on 30-31 March 2001 ... .
        The patch is available from:
        http://www.dcscripts.com/FAQ/sec_2001_03_31.html
        --

- 漏洞信息

3861
DCForum dcboard.cgi az Hidden Field Remote Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

DCForum contains a flaw that allows a remote attacker to execute commands remotely. The issue is due to the dcboard.cgi file not properly sanitizing the "az=" hidden field. If an attacker changes this field to include an arbitrary file with perl commands, they will be executed by the vulnerable server during script processing.

- 时间线

2003-03-31 Unknow
2001-04-16 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, DCScripts.com has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站