CVE-2001-0423
CVSS7.2
发布时间 :2001-07-02 00:00:00
修订时间 :2008-09-05 16:24:04
NMCOES    

[原文]Buffer overflow in ipcs in Solaris 7 x86 allows local users to execute arbitrary code via a long TZ (timezone) environmental variable, a different vulnerability than CAN-2002-0093.


[CNNVD]Solaris IPCS 时区变量本地缓冲区溢出漏洞(CNNVD-200107-036)

        CVE(CAN) ID: CAN-2001-0423
        
        
        
        Solaris 所带的ipcs程序缺省设置了SGID sys属性。由于它在处理一个环境变量
        
        时存在一个问题,可能导致本地用户提升权限。如果把环境变量TZ(时区)设置成
        
        一个很大的字符串,就可能导致一个缓冲区溢出的发生,攻击者可以以sys组权限
        
        执行任意代码。
        
        
        
        这个漏洞影响SPARC和x86平台,但是似乎只有x86平台下才可能攻击成功。
        
        
        
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0423
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0423
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200107-036
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2581
(VENDOR_ADVISORY)  BID  2581
http://archives.neohapsis.com/archives/bugtraq/2001-04/0217.html
(VENDOR_ADVISORY)  BUGTRAQ  20010412 Solaris ipcs vulnerability
http://xforce.iss.net/xforce/xfdb/6369
(VENDOR_ADVISORY)  XF  solaris-ipcs-bo(6369)

- 漏洞信息

Solaris IPCS 时区变量本地缓冲区溢出漏洞
高危 边界条件错误
2001-07-02 00:00:00 2005-05-13 00:00:00
本地  
        CVE(CAN) ID: CAN-2001-0423
        
        
        
        Solaris 所带的ipcs程序缺省设置了SGID sys属性。由于它在处理一个环境变量
        
        时存在一个问题,可能导致本地用户提升权限。如果把环境变量TZ(时区)设置成
        
        一个很大的字符串,就可能导致一个缓冲区溢出的发生,攻击者可以以sys组权限
        
        执行任意代码。
        
        
        
        这个漏洞影响SPARC和x86平台,但是似乎只有x86平台下才可能攻击成功。
        
        
        
        

- 公告与补丁

        
        
        临时解决方法:
        
        
        
        CNNVD建议您暂时去掉ipcs的sgid属性:
        
        chmod g-s /usr/bin/i86/ipcs
        
        chmod g-s /usr/bin/sparcv7/ipcs
        
        chmod g-s /usr/bin/sparcv9/ipcs
        
        
        
        厂商补丁:
        
        暂无
        

- 漏洞信息 (20751)

Solaris 7.0/8 IPCS Timezone Buffer Overflow Vulnerability (EDBID:20751)
solaris local
2001-04-12 Verified
0 Riley Hassell
N/A [点击下载]
source: http://www.securityfocus.com/bid/2581/info

Solaris is the variant of the UNIX Operating System distributed by Sun Microsystems. Solaris is designed as a scalable operating system for the Intel x86 and Sun Sparc platforms, and operates on machines varying from desktop to enterprise server.

A problem in the handling of environment variables by the SGID sys program ipcs could lead to local users gaining elevated privileges. Improper bounds checking of the buffer holding the TIMEZONE environment variable by the program could lead to a buffer overflow, and the overwriting of stack variables including the return address.

Therefore, it is possible for a local user to execute arbitrary code with the EUID of sys, and potentially gain further elevated privileges. 

Solaris 7 Sparc:
$ TZ=`perl -e 'print "A"x1107'`
$ /usr/bin/ipcs

Solaris 8 Sparc:
$ TZ=`perl -e 'print "A"x1199'`
$ /usr/bin/ipcs

Solaris x86:
$ TZ=`perl -e 'print "A"x1035'`
$ /usr/bin/i86/ipcs 		

- 漏洞信息

8685
Solaris ipcs TZ Variable Local Overflow
Local Access Required Input Manipulation
Loss of Integrity Solution Unknown
Exploit Public Uncoordinated Disclosure

- 漏洞描述

- 时间线

2001-04-12 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Solaris IPCS Timezone Buffer Overflow Vulnerability
Boundary Condition Error 2581
No Yes
2001-04-12 12:00:00 2009-07-11 06:06:00
This vulnerability was discovered by Riley Hassell <riley@eeye.com>, and announced to Bugtraq in an Eeye Security Advisory on April 12, 2001.

- 受影响的程序版本

Sun Solaris 8_x86
Sun Solaris 8_sparc
Sun Solaris 7.0_x86
Sun Solaris 7.0

- 漏洞讨论

Solaris is the variant of the UNIX Operating System distributed by Sun Microsystems. Solaris is designed as a scalable operating system for the Intel x86 and Sun Sparc platforms, and operates on machines varying from desktop to enterprise server.

A problem in the handling of environment variables by the SGID sys program ipcs could lead to local users gaining elevated privileges. Improper bounds checking of the buffer holding the TIMEZONE environment variable by the program could lead to a buffer overflow, and the overwriting of stack variables including the return address.

Therefore, it is possible for a local user to execute arbitrary code with the EUID of sys, and potentially gain further elevated privileges.

- 漏洞利用

Solaris 7 Sparc:
$ TZ=`perl -e 'print "A"x1107'`
$ /usr/bin/ipcs

Solaris 8 Sparc:
$ TZ=`perl -e 'print "A"x1199'`
$ /usr/bin/ipcs

Solaris x86:
$ TZ=`perl -e 'print "A"x1035'`
$ /usr/bin/i86/ipcs

- 解决方案

Sun has released patches to address this issue.


Sun Solaris 7.0_x86

Sun Solaris 7.0

Sun Solaris 8_x86

Sun Solaris 8_sparc

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站