CVE-2001-0390
CVSS5.0
发布时间 :2001-07-02 00:00:00
修订时间 :2008-09-05 16:23:59
NMCOES    

[原文]IBM Websphere/NetCommerce3 3.1.2 allows remote attackers to cause a denial of service by directly calling the macro.d2w macro with a long string of %0a characters.


[CNNVD]IBM Websphere/Net.Commerce的宏macro.d2w导致拒绝服务(CNNVD-200107-047)

        CVE(CAN) ID: CAN-2001-0390
        
        
        
        Net.Commerce是IBM发行的产品的Websphere平台的一部分。它提供了一些通用的特性使电子商务变得更加容易,其性能和可靠性也有独到之处。
        
        
        
        Net.Commerce包中存在的一个问题允许远程攻击者使Websphere服务器拒绝为其合法用户提供服务。这是由于Net.Commerce安装包中所包含的宏macro.d2w对长串处理不当。通过提交包含许多"%0a"的长串给该CGI程序,Websphere服务器将停止工作。
        
        
        
        远程用户可以利用这个漏洞来击溃Websphere服务器,从而使其拒绝为合法用户提供服务。
        
        
        
        <* 来源:ET LoWNOISE (et@cyberspace.org) *>
        
        
        
        
        
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ibm:net.commerce:2.0IBM Net.Commerce 2.0
cpe:/a:ibm:net.commerce:3.0IBM Net.Commerce 3.0
cpe:/a:ibm:net.commerce:3.1.1IBM Net.Commerce 3.1.1
cpe:/a:ibm:net.commerce_hosting_server:3.1.1IBM Net.Commerce Hosting Server 3.1.1
cpe:/a:ibm:websphere_application_server:5.1.0.3IBM WebSphere Application Server 5.1.0.3
cpe:/a:ibm:net.commerce_hosting_server:3.1.2IBM Net.Commerce Hosting Server 3.1.2
cpe:/a:ibm:net.commerce:3.1IBM Net.Commerce 3.1
cpe:/a:ibm:net.commerce:3.1.2IBM Net.Commerce 3.1.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0390
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0390
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200107-047
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2588
(VENDOR_ADVISORY)  BID  2588
http://www.securityfocus.com/archive/1/176100
(UNKNOWN)  BUGTRAQ  20010413 [LoWNOISE] IBM Websphere/NetCommerce3 DoS and one more.

- 漏洞信息

IBM Websphere/Net.Commerce的宏macro.d2w导致拒绝服务
中危 未知
2001-07-02 00:00:00 2006-08-21 00:00:00
远程  
        CVE(CAN) ID: CAN-2001-0390
        
        
        
        Net.Commerce是IBM发行的产品的Websphere平台的一部分。它提供了一些通用的特性使电子商务变得更加容易,其性能和可靠性也有独到之处。
        
        
        
        Net.Commerce包中存在的一个问题允许远程攻击者使Websphere服务器拒绝为其合法用户提供服务。这是由于Net.Commerce安装包中所包含的宏macro.d2w对长串处理不当。通过提交包含许多"%0a"的长串给该CGI程序,Websphere服务器将停止工作。
        
        
        
        远程用户可以利用这个漏洞来击溃Websphere服务器,从而使其拒绝为合法用户提供服务。
        
        
        
        <* 来源:ET LoWNOISE (et@cyberspace.org) *>
        
        
        
        
        
        

- 公告与补丁

        
        
        厂商补丁:
        
        
        
        暂无
        
        
        

- 漏洞信息 (20753)

IBM Websphere/Net.Commerce 3 CGI-BIN Macro Denial of Service Vulnerability (EDBID:20753)
cgi remote
2001-04-13 Verified
0 ET LoWNOISE
N/A [点击下载]
source: http://www.securityfocus.com/bid/2588/info

Net.Commerce is part of the Websphere platform of products distributed by IBM. Net.Commerce provides several versatile features to facilitate e-commerce, and features in performance and reliability.

A problem in the Net.Commerce package could allow a remote user to deny service to legitimate users of the service hosted by the Websphere server. This is due to the handling of long strings by the macro.d2w cgi included with a Net.Commerce installation. By supplying a long string of "%0a" characters to the CGI, the Websphere server ceases operation.

A remote user may use this vulnerability to crash the Websphere server, thus denying service to legitimate users. 

http://host/cgi-bin/ncommerce3/ExecMacro/macro.d2w/%0a%0a..(aprox 1000)..%0a 		

- 漏洞信息

9677
IBM WebSphere/NetCommerce3 macro.d2w Macro Parsing Remote DoS
Remote / Network Access Denial of Service
Loss of Availability Solution Unknown
Exploit Public Uncoordinated Disclosure

- 漏洞描述

- 时间线

2001-04-13 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

IBM Websphere/Net.Commerce CGI-BIN Macro Denial of Service Vulnerability
Unknown 2588
Yes No
2001-04-13 12:00:00 2009-07-11 06:06:00
This vulnerability was announced to Bugtraq by ET LoWNOISE <et@cyberspace.org> on April 13, 2001.

- 受影响的程序版本

IBM Net.Commerce Hosting Server 3.1.2
IBM Net.Commerce Hosting Server 3.1.1
IBM Net.Commerce 3.1.2
- IBM AIX 4.3.2
- IBM AIX 4.3.1
- IBM AIX 4.2.1
- Microsoft Windows NT 4.0
- Sun Solaris 7.0
- Sun Solaris 2.6
IBM Net.Commerce 3.1.1
IBM Net.Commerce 3.1
- HP HP-UX 11.0
- Microsoft Windows 2000 Professional
- Microsoft Windows NT 4.0
- Sun Solaris 2.5.1
- Sun Solaris 8_sparc
- Sun Solaris 7.0
- Sun Solaris 2.6
IBM Net.Commerce 3.0
IBM Net.Commerce 2.0

- 漏洞讨论

Net.Commerce is part of the Websphere platform of products distributed by IBM. Net.Commerce provides several versatile features to facilitate e-commerce, and features in performance and reliability.

A problem in the Net.Commerce package could allow a remote user to deny service to legitimate users of the service hosted by the Websphere server. This is due to the handling of long strings by the macro.d2w cgi included with a Net.Commerce installation. By supplying a long string of "%0a" characters to the CGI, the Websphere server ceases operation.

A remote user may use this vulnerability to crash the Websphere server, thus denying service to legitimate users.

- 漏洞利用

http://host/cgi-bin/ncommerce3/ExecMacro/macro.d2w/%0a%0a..(aprox 1000)..%0a

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站