CVE-2001-0327
CVSS5.0
发布时间 :2001-07-02 00:00:00
修订时间 :2008-09-05 16:23:50
NMCO    

[原文]iPlanet Web Server Enterprise Edition 4.1 and earlier allows remote attackers to retrieve sensitive data from memory allocation pools, or cause a denial of service, via a URL-encoded Host: header in the HTTP request, which reveals memory in the Location: header that is returned by the server.


[CNNVD]iPlanet Web Server应答头远程缓冲区溢出漏洞(CNNVD-200107-045)

        
        Sun iPlanet Web是一款Sun Microsystems公司开发的商业WEB服务器程序。
        iPlanet Web不正确处理应答头数据可导致缓冲区溢出,远程攻击者可以利用这个漏洞获得以前的HTTP请求和应答的数据,如COOKIE信息,表单发送信息,用户名和密码等敏感信息。
        iPlanet Web根据用户提供的数据来构建应答数据头,攻击者提交包含畸形的'Host:'头字段数据的HTTP请求,可导致服务器读取以前内存池中的敏感数据,使攻击者获得一些当前用户会话的验证信息,之前HTTP请求中的信息包括COOKIE,表单发送信息,用户名和密码等。
        使用特殊的请求长度和导致服务线程/进程崩溃,因此可以对服务程序进行拒绝服务攻击。
        <*链接:http://www.atstake.com/research/advisories/2001/a041601-1.txt
        *>

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0327
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0327
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200107-045
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/276767
(UNKNOWN)  CERT-VN  VU#276767
http://www.atstake.com/research/advisories/2001/a041601-1.txt
(VENDOR_ADVISORY)  ATSTAKE  A041601-1
http://www.iplanet.com/products/iplanet_web_enterprise/iwsalert4.16.html
(UNKNOWN)  CONFIRM  http://www.iplanet.com/products/iplanet_web_enterprise/iwsalert4.16.html
http://www.osvdb.org/5704
(UNKNOWN)  OSVDB  5704

- 漏洞信息

iPlanet Web Server应答头远程缓冲区溢出漏洞
中危 未知
2001-07-02 00:00:00 2006-09-22 00:00:00
远程  
        
        Sun iPlanet Web是一款Sun Microsystems公司开发的商业WEB服务器程序。
        iPlanet Web不正确处理应答头数据可导致缓冲区溢出,远程攻击者可以利用这个漏洞获得以前的HTTP请求和应答的数据,如COOKIE信息,表单发送信息,用户名和密码等敏感信息。
        iPlanet Web根据用户提供的数据来构建应答数据头,攻击者提交包含畸形的'Host:'头字段数据的HTTP请求,可导致服务器读取以前内存池中的敏感数据,使攻击者获得一些当前用户会话的验证信息,之前HTTP请求中的信息包括COOKIE,表单发送信息,用户名和密码等。
        使用特殊的请求长度和导致服务线程/进程崩溃,因此可以对服务程序进行拒绝服务攻击。
        <*链接:http://www.atstake.com/research/advisories/2001/a041601-1.txt
        *>

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 使用atstake开发的第三方NSAPI数据验证模块:
         Usage:
         In [server-root]/[server-instance]/config/obj.conf:
         ...
         Init fn="load-modules" shlib="[path to libs]/long.so"
         funcs="bounds_check"
        
         # Make sure this function is the first to be called
         NameTrans fn=bounds_check maxlength=100
         ...
         ----- BEGIN -----
         #include "nsapi.h"
         static int max_req_len = 0;
         NSAPI_PUBLIC int bounds_check(pblock *pb, Session *sn,
         Request *rq) {
         char *temp;
         max_req_len = atoi(pblock_findval("maxlength", pb));
         temp = pblock_findval("host", rq->headers);
         if (temp != NULL) {
         if (strlen(temp) > max_req_len) {
         log_error(LOG_SECURITY, "bounds_check", sn, rq,
         "Overly long host header (%d bytes)...
         aborting.",
         strlen(temp));
         protocol_status(sn, rq, 440, "Go Away Kid");
         return REQ_ABORTED;
         }
         }
         return REQ_NOACTION;
         }
         ----- END -----
        厂商补丁:
        iPlanet E-Commerce Solutions
        ----------------------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载升级到iPlanet Web Server 4.1sp7版本:
        
        http://www.iplanet.com/

- 漏洞信息

5704
iPlanet Web Server Enterprise Edition URL-encoded Host: Information Disclosure
Remote / Network Access Denial of Service, Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Availability Upgrade
Exploit Public Vendor Verified

- 漏洞描述

iPlanet Web Server Enterprise Edition 4.1 and earlier contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when an attacker fills the Host: header with characters that will be automatically URL-encoded by iPlanet before response handlers are called, which can either: disclose the heap contents written by other server functions information resulting in a loss of confidentiality; or cause a server thread/process to crash resulting in a loss of availability.

- 时间线

2001-04-16 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.1 SP7 or higher, as it has been reported to fix this vulnerability. It is also possible to implement the NSAPI module that will shield the earlier versions of the server from the problem.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站