CVE-2001-0301
CVSS10.0
发布时间 :2001-05-03 00:00:00
修订时间 :2008-09-05 16:23:46
NMCO    

[原文]Buffer overflow in Analog before 4.16 allows remote attackers to execute arbitrary commands by using the ALIAS command to construct large strings.


[CNNVD]Analog缓冲区溢出漏洞(CNNVD-200105-007)

        Analog 4.16之前版本存在缓冲区溢出漏洞。远程攻击者可以通过使用ALIAS命令去构造超大字符串执行任意命令。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:stephen_turner:analog:4.15
cpe:/a:stephen_turner:analog:4.90_beta2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0301
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0301
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200105-007
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2377
(VENDOR_ADVISORY)  BID  2377
http://www.debian.org/security/2001/dsa-033
(VENDOR_ADVISORY)  DEBIAN  DSA-033
http://www.analog.cx/security2.html
(VENDOR_ADVISORY)  CONFIRM  http://www.analog.cx/security2.html
http://archives.neohapsis.com/archives/linux/redhat/2001-q1/0056.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2001:017
http://archives.neohapsis.com/archives/bugtraq/2001-02/0264.html
(VENDOR_ADVISORY)  BUGTRAQ  20010213 Security advisory for analog
http://xforce.iss.net/xforce/xfdb/6105
(UNKNOWN)  XF  analog-alias-bo(6105)
http://www.osvdb.org/1762
(UNKNOWN)  OSVDB  1762

- 漏洞信息

Analog缓冲区溢出漏洞
危急 缓冲区溢出
2001-05-03 00:00:00 2005-05-02 00:00:00
远程  
        Analog 4.16之前版本存在缓冲区溢出漏洞。远程攻击者可以通过使用ALIAS命令去构造超大字符串执行任意命令。

- 公告与补丁

        

- 漏洞信息

1762
Analog ALIAS Command Overflow
Local Access Required, Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Analog contains a flaw that allows a local or remote user (depending on configuration) to gain administrative privileges. The issue is due to a buffer overflow in the ALIAS command. With a specially crafted request, an attacker can gain admin privileges resulting in a loss of integrity.

- 时间线

2001-02-13 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.16 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站