CVE-2001-0249
CVSS10.0
发布时间 :2001-06-18 00:00:00
修订时间 :2008-09-10 15:07:35
NMCOS    

[原文]Heap overflow in FTP daemon in Solaris 8 allows remote attackers to execute arbitrary commands by creating a long pathname and calling the LIST command, which uses glob to generate long strings.


[CNNVD]Solaris ftpd glob() 扩展堆溢出漏洞(CNNVD-200106-082)

        CVE(CAN) ID: CAN-2001-0249
        
        
        
        很多系统的FTPD守护程序包含一个glob()函数,它实现文件名的模式匹配,它遵
        
        循与Unix shell同样的原则。
        
        
        
        当一个FTP守护程序收到一个请求,它包含一个以'~'号开头的文件名,它通常会
        
        将整个文件名交给glob()函数去处理,以解析特定的home目录并获得一个全路径。
        
        这可能导致一个非常大的字符串被传回给主处理程序。
        
        
        
        在Solaris下,通过使用LIST命令,可以造成一个可以利用的堆溢出问题。当
        
        FTP守护程序试图使用无边界检查的字符串操作来构造一个字符串,以便执行
        
        /bin/ls程序时,会导致溢出发生。
        
        
        
        
        
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sun:solaris:8.0
cpe:/o:sun:solaris:2.5
cpe:/o:sun:solaris:2.6
cpe:/o:sun:solaris:7.0
cpe:/o:sun:solaris:2.4
cpe:/o:sun:solaris:2.3
cpe:/o:sun:solaris:2.5.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0249
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0249
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200106-082
(官方数据源) CNNVD

- 其它链接及资源

http://www.cert.org/advisories/CA-2001-07.html
(VENDOR_ADVISORY)  CERT  CA-2001-07
http://www.securityfocus.com/bid/2550
(VENDOR_ADVISORY)  BID  2550
http://xforce.iss.net/static/6332.php
(UNKNOWN)  XF  ftp-glob-expansion(6332)
http://www.nai.com/research/covert/advisories/048.asp
(UNKNOWN)  NAI  20010409 Globbing Vulnerabilities in Multiple FTP Daemons

- 漏洞信息

Solaris ftpd glob() 扩展堆溢出漏洞
危急 边界条件错误
2001-06-18 00:00:00 2005-10-20 00:00:00
远程  
        CVE(CAN) ID: CAN-2001-0249
        
        
        
        很多系统的FTPD守护程序包含一个glob()函数,它实现文件名的模式匹配,它遵
        
        循与Unix shell同样的原则。
        
        
        
        当一个FTP守护程序收到一个请求,它包含一个以'~'号开头的文件名,它通常会
        
        将整个文件名交给glob()函数去处理,以解析特定的home目录并获得一个全路径。
        
        这可能导致一个非常大的字符串被传回给主处理程序。
        
        
        
        在Solaris下,通过使用LIST命令,可以造成一个可以利用的堆溢出问题。当
        
        FTP守护程序试图使用无边界检查的字符串操作来构造一个字符串,以便执行
        
        /bin/ls程序时,会导致溢出发生。
        
        
        
        
        
        

- 公告与补丁

        
        
        临时解决方法:
        
        
        
        如果您不需要FTP服务,请暂时关闭FTP. 禁止匿名用户登录或拥有可写目录。
        
        
        
        厂商补丁:
        
        暂无

- 漏洞信息

8681
Solaris FTP Daemon LIST Glob Arbitrary Command Execution
Local Access Required Input Manipulation
Loss of Integrity

- 漏洞描述

A local overflow exists in Solaris. The LIST command fails to validate user-supplied input before passing it into the glob() fucntion resulting in a heap overflow. With a specially crafted request, an attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2001-04-09 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Sun has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Solaris ftpd glob() Expansion LIST Heap Overflow Vulnerability
Boundary Condition Error 2550
Yes No
2001-04-09 12:00:00 2009-07-11 06:06:00
This vulnerability was discovered by Anthony Osborne and John McDonald of NAI's COVERT labs and published on April 9, 2001.

- 受影响的程序版本

Sun Solaris 2.5.1
Sun Solaris 8_sparc
Sun Solaris 7.0
Sun Solaris 2.6
Sun Solaris 2.5
Sun Solaris 2.4
Sun Solaris 2.3

- 漏洞讨论

The Solaris ftp daemon contains a heap-based buffer overflow condition. The overflow occurs when the LIST command is issued with an argument that expands into an oversized string after being processed by glob().

This buffer overflow occurs in memory that is dynamically allocated. It may be possible for attackers to exploit this vulnerability and execute arbitrary code on the affected host.

To exploit this, the attacker must be able to create directories on the target host.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Fixes available:


Sun Solaris 2.6

Sun Solaris 7.0

Sun Solaris 8_sparc

Sun Solaris 2.5

Sun Solaris 2.5.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站