CVE-2001-0201
CVSS7.5
发布时间 :2001-03-26 00:00:00
修订时间 :2008-09-10 15:07:27
NMCOS    

[原文]The Postaci frontend for PostgreSQL does not properly filter characters such as semicolons, which could allow remote attackers to execute arbitrary SQL queries via the deletecontact.php program.


[CNNVD]Postaci任意SQL命令注入漏洞(CNNVD-200103-092)

        PostgreSQL的Postaci frontend不正确过滤字符如分号等,远程攻击者可以借助deletecontact.php程序执行任意SQL查询。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:umut_gokbayrak:postaci:1.1.2
cpe:/a:umut_gokbayrak:postaci:1.1.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0201
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0201
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200103-092
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/5972
(UNKNOWN)  XF  postaci-sql-command-injection
http://www.securityfocus.com/bid/2230
(VENDOR_ADVISORY)  BID  2230
http://archives.neohapsis.com/archives/bugtraq/2001-01/0287.html
(VENDOR_ADVISORY)  BUGTRAQ  20010117 Postaci allows arbitrary SQL query execution

- 漏洞信息

Postaci任意SQL命令注入漏洞
高危 输入验证
2001-03-26 00:00:00 2005-10-20 00:00:00
远程  
        PostgreSQL的Postaci frontend不正确过滤字符如分号等,远程攻击者可以借助deletecontact.php程序执行任意SQL查询。

- 公告与补丁

        Currently the SecurityFocus staff are not ware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 漏洞信息

9497
Postaci Webmail PostgreSQL Version deletecontact.php item_id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Postaci Webmail contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the $item_id variable in the deletecontact.php script is not verified properly and will allow an attacker to inject or manipulate SQL queries. This vulnerability only exists in the PostgreSQL version of Postaci Webmail.

- 时间线

2001-01-17 Unknow
2001-01-17 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Postaci Arbitrary SQL Command Injection Vulnerability
Input Validation Error 2230
Yes No
2001-01-17 12:00:00 2009-07-11 04:46:00
This vulnerability was first announced by Berk Demir <berk@linux.org.tr> on January 17, 2001 via Bugtraq.

- 受影响的程序版本

Umut Gokbayrak Postaci 1.1.3
Umut Gokbayrak Postaci 1.1.2
+ Debian Linux 2.2 sparc
+ Debian Linux 2.2 sparc
+ Debian Linux 2.2 powerpc
+ Debian Linux 2.2 powerpc
+ Debian Linux 2.2 arm
+ Debian Linux 2.2 arm
+ Debian Linux 2.2 alpha
+ Debian Linux 2.2 alpha
+ Debian Linux 2.2 68k
+ Debian Linux 2.2
+ Debian Linux 2.2

- 漏洞讨论

Postaci is a freely available, open source webmail interface designed for a multiple user webmail environment, and backend of a SQL database. It is written and maintained by Umut Gokbayrak.

A problem in the software may allow remote users to pass malicious queries to the database server. This affects Postaci implementations that are backended by the PostgreSQL database, and does not affect those using a MySQL implementation. It is possible to append or inject arbitrary SQL commands to the request of a legitimate user due to the way the commands are passed to the PostgreSQL database. Commands used by the Postaci software are passed to the database using PHP pages, and FORM methods. The FORM methods passed by Postaci to the PostgreSQL database allow for the entry of semi-colons, which can be used to append database queries or other commands to the end of a command sent by a legitimate user. This makes it possible for a user with malicious motives to inject and execute arbitrary commands on the database.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Currently the SecurityFocus staff are not ware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站