CVE-2001-0164
CVSS7.5
发布时间 :2001-06-02 00:00:00
修订时间 :2008-09-05 16:23:25
NMCO    

[原文]Buffer overflow in Netscape Directory Server 4.12 and earlier allows remote attackers to cause a denial of service or execute arbitrary commands via a malformed recipient field.


[CNNVD]Netscape目录服务器SMTP远程缓冲区溢出漏洞(CNNVD-200106-005)

        
        Netscape目录服务器是一种扩展的服务器解决方案,这种服务器存储、查询和管理"白页"式目录信息,例如:姓名、电话号码、电子邮件地址和共用密钥的认证。
        Netscape目录服务器在处理畸形邮件时处理不正确,远程攻击者可以利用这个漏洞对服务程序进行缓冲区溢出攻击,可能以服务程序进程在系统上执行任意指令。
        Netscape的消息服务器包含访问和发送邮件的服务,如WEBMAIL接口和SMTP服务器,这两个都与目录服务器通信来进行邮件操作。用户连接SMTP服务器,发送在'RCPT TO:'字段包含超长"号(HEX 0x22)的字符串的恶意消息,当这个消息通过SMTP服务连接到Netscape目录服务器解析时,会调用在libslapd.dll中的escape_string_with_punctuation(),由于没有对'RCPT TO:'字段进行正确的检查,可发生缓冲区溢出,精心构建提交数据可能以目录服务器进程在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0164
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0164
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200106-005
(官方数据源) CNNVD

- 其它链接及资源

http://www.atstake.com/research/advisories/2001/a030701-1.txt
(VENDOR_ADVISORY)  ATSTAKE  A030701-1
http://xforce.iss.net/static/6233.php
(UNKNOWN)  XF  netscape-directory-server-bo(6233)

- 漏洞信息

Netscape目录服务器SMTP远程缓冲区溢出漏洞
高危 未知
2001-06-02 00:00:00 2006-08-31 00:00:00
远程  
        
        Netscape目录服务器是一种扩展的服务器解决方案,这种服务器存储、查询和管理"白页"式目录信息,例如:姓名、电话号码、电子邮件地址和共用密钥的认证。
        Netscape目录服务器在处理畸形邮件时处理不正确,远程攻击者可以利用这个漏洞对服务程序进行缓冲区溢出攻击,可能以服务程序进程在系统上执行任意指令。
        Netscape的消息服务器包含访问和发送邮件的服务,如WEBMAIL接口和SMTP服务器,这两个都与目录服务器通信来进行邮件操作。用户连接SMTP服务器,发送在'RCPT TO:'字段包含超长"号(HEX 0x22)的字符串的恶意消息,当这个消息通过SMTP服务连接到Netscape目录服务器解析时,会调用在libslapd.dll中的escape_string_with_punctuation(),由于没有对'RCPT TO:'字段进行正确的检查,可发生缓冲区溢出,精心构建提交数据可能以目录服务器进程在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Netscape
        --------
        供应商建议用户升级到Directory Server 4.13版本以上,另外供应商建议NMS 4.15用户采用Patch 4。
        
        http://www.netscape.com

- 漏洞信息

7175
Netscape Directory Server Recipient Field Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2001-03-07 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站