发布时间 :2001-03-12 00:00:00
修订时间 :2016-10-17 22:09:41

[原文]Directory traversal vulnerability in eXtropia bbs_forum.cgi 1.0 allows remote attackers to read arbitrary files via a .. (dot dot) attack on the file parameter.

[CNNVD]eXtropia bbs_forum.cgi目录遍历漏洞(CNNVD-200103-028)

        eXtropia bbs_forum.cgi 1.0版本存在目录遍历漏洞。远程攻击者借助file参数中 .. (点 点)攻击读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20010107 Advisory #3.1
(UNKNOWN)  XF  http-cgi-bbs-forum(5906)

- 漏洞信息

eXtropia bbs_forum.cgi目录遍历漏洞
中危 路径遍历
2001-03-12 00:00:00 2005-05-02 00:00:00
        eXtropia bbs_forum.cgi 1.0版本存在目录遍历漏洞。远程攻击者借助file参数中 .. (点 点)攻击读取任意文件。

- 公告与补丁


- 漏洞信息 (20533)

eXtropia bbs_forum.cgi 1.0 Remote Arbitrary Command Execution Vulnerability (EDBID:20533)
cgi remote
2001-01-07 Verified
0 scott
N/A [点击下载]

bbs_forum.cgi is a popular Perl cgi script from It supports the creation and maintenance of web-based threaded discussion forums.

Version 1.0 of bbs_forum.cgi fails to properly validate user-supplied, URL-encoded input to the read environment variable. Maliciously-formed URLs submitted to the script may contain references to files on the host's filesystem, as well as shell commands which will be run with the privilege level of the webserver (ie, user 'nobody'). As a result, unpatched affected versions of the script permit an attacker to execute arbitrary code and to read arbitrary files on the vulnerable system. 


note: The section: <forum_name> must be a valid forum on the webserver. 		

- 漏洞信息

Extropia WebBBS bbs_forum.cgi read Parameter Traversal Remote Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

eXtropia WebBBS contains a flaw that allows a remote attacker to execute arbitrary commands or read arbitrary files. The issue is due to the bbs_forum.cgi script not validating input to the "read" variable. By using a standard traversal attack (../../), an attacker can execute arbitrary commands.

- 时间线

2001-01-07 2001-01-03
2001-01-07 Unknow

- 解决方案

Upgrade to version 8.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete