CVE-2001-0103
CVSS4.6
发布时间 :2001-02-12 00:00:00
修订时间 :2008-09-05 16:23:16
NMCOS    

[原文]CoffeeCup Direct and Free FTP clients uses weak encryption to store passwords in the FTPServers.ini file, which could allow attackers to easily decrypt the passwords.


[CNNVD]CoffeeCup FTP客户端过弱密码加密漏洞(CNNVD-200102-025)

        CoffeeCup Direct和Free FTP客户端使用过弱加密储存FTPServers.ini文件密码。攻击者可以利用该漏洞轻松破解密码。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-310 [密码学安全问题]

- CPE (受影响的平台与产品)

cpe:/a:coffeecup_software:coffeecup_direct_ftp:1.0
cpe:/a:coffeecup_software:coffeecup_free_ftp:1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0103
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0103
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200102-025
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/5744.php
(VENDOR_ADVISORY)  XF  coffeecup-ftp-weak-encryption
http://www.securityfocus.com/bid/2107
(VENDOR_ADVISORY)  BID  2107

- 漏洞信息

CoffeeCup FTP客户端过弱密码加密漏洞
中危 设计错误
2001-02-12 00:00:00 2005-10-20 00:00:00
本地  
        CoffeeCup Direct和Free FTP客户端使用过弱加密储存FTPServers.ini文件密码。攻击者可以利用该漏洞轻松破解密码。

- 公告与补丁

        Currently the SecurityFocus staff are not ware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 漏洞信息

12146
CoffeeCup FTP Client FTPServers.ini Password Encryption Weakness
Local / Remote Cryptographic
Loss of Confidentiality Solution Unknown

- 漏洞描述

- 时间线

2000-12-14 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

CoffeeCup FTP Clients Weak Password Encryption Vulnerability
Design Error 2107
No Yes
2000-12-14 12:00:00 2009-07-11 04:46:00
reported to SecurityFocus by Julio César Hernández <jcesar@hispasec.com> on 14 Dec, 2000.

- 受影响的程序版本

CoffeeCup Software CoffeeCup Free FTP 1.0
CoffeeCup Software CoffeeCup Direct FTP 1.0

- 漏洞讨论

A vulnerability exists in the FTP clients CoffeCupt Direct and CoffeeCup Free.

The clients use the file FTPServers.ini to store password information for sites to which the client has been connected. The encryption method designed to obfuscate these passwords can be easily defeated.

As a result, a malicious user able to read the FTPServers.ini will be able to obtain the passwords to any of the stored FTP servers, compromising their security.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any publicly available exploits for this vulnerability. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Currently the SecurityFocus staff are not ware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站