CVE-2001-0073
CVSS2.1
发布时间 :2001-02-12 00:00:00
修订时间 :2008-09-05 16:23:12
NMCOS    

[原文]Buffer overflow in the find_default_type function in libsecure in NSA Security-enhanced Linux, which may allow attackers to modify critical data in memory.


[CNNVD]Security-Enhanced Linux缓冲区溢出漏洞(CNNVD-200102-073)

        NSA Security-enhanced Linux的libsecure的find_default_type函数存在缓冲区溢出漏洞。攻击者修改内存中决定性的数据。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0073
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0073
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200102-073
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2154
(VENDOR_ADVISORY)  BID  2154
http://www.securityfocus.com/archive/1/153188
(VENDOR_ADVISORY)  BUGTRAQ  20001226 buffer overflow in libsecure (NSA Security-enhanced Linux)

- 漏洞信息

Security-Enhanced Linux缓冲区溢出漏洞
低危 缓冲区溢出
2001-02-12 00:00:00 2005-10-20 00:00:00
本地  
        NSA Security-enhanced Linux的libsecure的find_default_type函数存在缓冲区溢出漏洞。攻击者修改内存中决定性的数据。

- 公告与补丁

        Currently the SecurityFocus staff are not ware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 漏洞信息

7682
NSA Security-enhanced Linux libsecure find_default_type Function Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2000-12-26 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Security-Enhanced Linux Buffer Overflow Vulnerability
Boundary Condition Error 2154
No Yes
2000-12-26 12:00:00 2009-07-11 04:46:00
This vulnerability was announced by Matt Power <mhpower@bos.bindview.com> on December 26, 2000.

- 受影响的程序版本

NSA Security-Enhanced Linux slinux-200012181053
- RedHat Linux 6.1 i386

- 漏洞讨论

Security-Enhanced Linux is an add-on access control infrastructure developed and distributed by the U.S. National Security Agency. A problem exists which could allow the altering of sensitive information on a running system.

The problem occurs in the libsecure/get_default_type.c file. get_default_type attempts to allocate buffer space by extracting the default type from /etc/security/default_type and copying the result to a buffer. The buffer that is created, however, is generally one byte too small and creates an ideal situation for a buffer overflow attack. This vulnerability can be exploited by a malicious user to potentially overwrite malloc()'d fields that may contain other application data, or overhead data that another application was relying upon.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Currently the SecurityFocus staff are not ware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站