CVE-2001-0060
CVSS10.0
发布时间 :2001-02-12 00:00:00
修订时间 :2008-09-05 16:23:10
NMCO    

[原文]Format string vulnerability in stunnel 3.8 and earlier allows attackers to execute arbitrary commands via a malformed ident username.


[CNNVD]stunnel格式化字符串漏洞(CNNVD-200102-047)

        stunnel 3.8及其早期版本版本存在格式化字符串漏洞。攻击者可以借助畸形ident用户名执行任意命令。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:stunnel:stunnel:3.8
cpe:/a:stunnel:stunnel:3.4a
cpe:/a:stunnel:stunnel:3.7
cpe:/a:stunnel:stunnel:3.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0060
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0060
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200102-047
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/2128
(VENDOR_ADVISORY)  BID  2128
http://www.securityfocus.com/archive/1/151719
(VENDOR_ADVISORY)  BUGTRAQ  20001218 Stunnel format bug
http://archives.neohapsis.com/archives/bugtraq/2000-12/0337.html
(VENDOR_ADVISORY)  BUGTRAQ  20001209 Trustix Security Advisory - stunnel
http://xforce.iss.net/static/5807.php
(VENDOR_ADVISORY)  XF  stunnel-format-logfile
http://www.redhat.com/support/errata/RHSA-2000-129.html
(UNKNOWN)  REDHAT  RHSA-2000:129
http://www.debian.org/security/2001/dsa-009
(UNKNOWN)  DEBIAN  DSA-009
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000363
(UNKNOWN)  CONECTIVA  CLA-2000:363

- 漏洞信息

stunnel格式化字符串漏洞
危急 格式化字符串
2001-02-12 00:00:00 2006-09-05 00:00:00
远程  
        stunnel 3.8及其早期版本版本存在格式化字符串漏洞。攻击者可以借助畸形ident用户名执行任意命令。

- 公告与补丁

        

- 漏洞信息

1696
Stunnel syslog() Function Remote Logfile Format String Arbitrary Command Execution
Remote / Network Access, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2000-12-13 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站