CVE-2001-0042
CVSS5.0
发布时间 :2001-02-16 00:00:00
修订时间 :2008-09-05 16:23:07
NMCOES    

[原文]PHP 3.x (PHP3) on Apache 1.3.6 allows remote attackers to read arbitrary files via a modified .. (dot dot) attack containing "%5c" (encoded backslash) sequences.


[CNNVD]带Php文件的Apache Web服务器泄露漏洞(CNNVD-200102-102)

        Apache 1.3.6版本的PHP 3.x (PHP3)存在漏洞。远程攻击者借助包含"%5c"(编码的反斜杠)序列的修改的 .. (点 点)读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2001-0042
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2001-0042
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200102-102
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/5659.php
(VENDOR_ADVISORY)  XF  apache-php-disclose-files
http://www.securityfocus.com/bid/2060
(VENDOR_ADVISORY)  BID  2060
http://www.securityfocus.com/archive/1/149210
(VENDOR_ADVISORY)  BUGTRAQ  20001206 CHINANSL Security Advisory(CSA-200011)

- 漏洞信息

带Php文件的Apache Web服务器泄露漏洞
中危 输入验证
2001-02-16 00:00:00 2006-08-03 00:00:00
远程※本地  
        Apache 1.3.6版本的PHP 3.x (PHP3)存在漏洞。远程攻击者借助包含"%5c"(编码的反斜杠)序列的修改的 .. (点 点)读取任意文件。

- 公告与补丁

        Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 漏洞信息 (20466)

Apache 1.3 Web Server with Php 3 File Disclosure Vulnerability (EDBID:20466)
multiple remote
2000-12-06 Verified
0 china nsl
N/A [点击下载]
source: http://www.securityfocus.com/bid/2060/info

Apache Web Server is subject to disclose files to unauthorized users when used in conjunction with the PHP3 script language.

By requesting a specially crafted URL by way of php, it is possible for a remote user to gain read access to a known file that resides on the target host.

Successful exploitation of this vulnerability could lead to the disclosure of sensitive information and possibly assist in further attacks against the victim. 

http://target/index.php3.%5c../..%5cconf/httpd.conf 		

- 漏洞信息

9694
PHP3 on Apache HTTP Server Encoded Traversal Arbitrary File Access
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality
Exploit Public

- 漏洞描述

- 时间线

2000-12-06 Unknow
2000-12-06 Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Apache Web Server with Php 3 File Disclosure Vulnerability
Input Validation Error 2060
Yes Yes
2000-12-06 12:00:00 2009-07-11 03:56:00
Discovered and posted to Bugtraq by china nsl <webmaster@chinansl.com> on Dec 6, 2000.

- 受影响的程序版本

Apache Software Foundation Apache 1.3
+ Apple Mac OS X 10.3.2
+ Apple Mac OS X 10.3.1
+ Apple Mac OS X 10.3
+ Apple Mac OS X 10.2.8
+ Apple Mac OS X 10.2.7
+ Apple Mac OS X 10.2.6
+ Apple Mac OS X 10.2.5
+ Apple Mac OS X 10.2.4
+ Apple Mac OS X 10.2.3
+ Apple Mac OS X 10.2.2
+ Apple Mac OS X 10.2.1
+ Apple Mac OS X 10.2
+ Apple Mac OS X 10.1.5
+ Apple Mac OS X 10.1.4
+ Apple Mac OS X 10.1.3
+ Apple Mac OS X 10.1.2
+ Apple Mac OS X 10.1.1
+ Apple Mac OS X 10.1
+ Apple Mac OS X Server 10.3.2
+ Apple Mac OS X Server 10.3.1
+ Apple Mac OS X Server 10.3
+ Apple Mac OS X Server 10.2.8
+ Apple Mac OS X Server 10.2.7
+ Apple Mac OS X Server 10.2.6
+ Apple Mac OS X Server 10.2.5
+ Apple Mac OS X Server 10.2.4
+ Apple Mac OS X Server 10.2.3
+ Apple Mac OS X Server 10.2.2
+ Apple Mac OS X Server 10.2.1
+ Apple Mac OS X Server 10.2
+ Apple Mac OS X Server 10.1.5
+ Apple Mac OS X Server 10.1.4
+ Apple Mac OS X Server 10.1.3
+ Apple Mac OS X Server 10.1.2
+ Apple Mac OS X Server 10.1.1
+ Apple Mac OS X Server 10.1
- Microsoft Windows 2000 Professional
- Microsoft Windows NT 4.0

- 漏洞讨论

Apache Web Server is subject to disclose files to unauthorized users when used in conjunction with the PHP3 script language.

By requesting a specially crafted URL by way of php, it is possible for a remote user to gain read access to a known file that resides on the target host.

Successful exploitation of this vulnerability could lead to the disclosure of sensitive information and possibly assist in further attacks against the victim.

- 漏洞利用

The following example has been provided by china nsl &lt;webmaster@chinansl.com&gt;:

http://target/index.php3.%5c../..%5cconf/httpd.conf

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站