CVE-2000-1219
CVSS7.5
发布时间 :2000-11-01 00:00:00
修订时间 :2008-09-05 16:22:57
NMCO    

[原文]The -ftrapv compiler option in gcc and g++ 3.3.3 and earlier does not handle all types of integer overflows, which may leave applications vulnerable to vulnerabilities related to overflows.


[CNNVD]gcc和g++应用程序侵害漏洞(CNNVD-200011-001)

        gcc和g++ 3.3.3版本及之前版本中的-ftrapv编译选项不处理所有整数溢出类型,使应用程序可能易受与缓冲区有关的漏洞的侵害。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gnu:g%2B%2B:3.3.3GNU g++ 3.3.3
cpe:/a:gnu:gcc:3.3.3GNU gcc 3.3.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-1219
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-1219
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200011-001
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/540517
(UNKNOWN)  CERT-VN  VU#540517
http://gcc.gnu.org/ml/gcc-bugs/2002-05/msg00198.html
(UNKNOWN)  MLIST  [gcc-bugs] 20020506 c/6586: -ftrapv doesn't catch multiplication overflow

- 漏洞信息

gcc和g++应用程序侵害漏洞
高危 缓冲区溢出
2000-11-01 00:00:00 2005-10-20 00:00:00
远程  
        gcc和g++ 3.3.3版本及之前版本中的-ftrapv编译选项不处理所有整数溢出类型,使应用程序可能易受与缓冲区有关的漏洞的侵害。

- 公告与补丁

        

- 漏洞信息

19098
Gnu GCC / g++ -ftrapv Option Integer Overflow Handling Issue
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2002-05-06 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站