CVE-2000-1214
CVSS4.6
发布时间 :2000-10-18 00:00:00
修订时间 :2016-10-17 22:09:20
NMCOS    

[原文]Buffer overflows in the (1) outpack or (2) buf variables of ping in iputils before 20001010, as distributed on Red Hat Linux 6.2 through 7J and other operating systems, may allow local users to gain privileges.


[CNNVD]RedHat Linux ping缓冲区溢出漏洞(CNNVD-200010-004)

        分配在Red Hat Linux 6.2至7J和其他操作系统中iputils 20001010之前版本的(1)outpack或者(2)buf多变的ping存在缓冲区溢出漏洞。本地用户利用该漏洞提升特权。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:immunix:immunix:6.2
cpe:/o:redhat:linux:7.0Red Hat Linux 7.0
cpe:/o:redhat:linux:6.2::alpha
cpe:/a:iputils:iputils:2000-10-10
cpe:/o:redhat:linux:6.2::i386
cpe:/o:redhat:linux:6.2::sparc

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-1214
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-1214
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200010-004
(官方数据源) CNNVD

- 其它链接及资源

http://archives.neohapsis.com/archives/bugtraq/2000-10/0429.html
(UNKNOWN)  BUGTRAQ  20001030 Trustix Security Advisory - ping gnupg ypbind
http://marc.info/?l=bugtraq&m=97208562830613&w=2
(UNKNOWN)  BUGTRAQ  20001020 Re: [RHSA-2000:087-02] Potential security problems in ping fixed.
http://marc.info/?l=bugtraq&m=97249980727834&w=2
(UNKNOWN)  BUGTRAQ  20001025 Immunix OS Security Update for ping package
http://www.iss.net/security_center/static/5431.php
(VENDOR_ADVISORY)  XF  ping-buf-bo(5431)
http://www.redhat.com/support/errata/RHSA-2000-087.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2000:087
http://www.securityfocus.com/bid/1813
(UNKNOWN)  BID  1813

- 漏洞信息

RedHat Linux ping缓冲区溢出漏洞
中危 缓冲区溢出
2000-10-18 00:00:00 2006-09-15 00:00:00
本地  
        分配在Red Hat Linux 6.2至7J和其他操作系统中iputils 20001010之前版本的(1)outpack或者(2)buf多变的ping存在缓冲区溢出漏洞。本地用户利用该漏洞提升特权。

- 公告与补丁

        RedHat has released fixed packages.
        Trustix recently released several updated packages:
        iputils: Fixes serveral problems in ping including a buffer overflow.
        gnupg: Fixed a serious bug which could lead to false signature verification results when more than one signature is fed to gpg.
        ypbind: Local root exploit. Linux ypbind
        Users of TSL 1.0x and 1.1 that worry about local security should definitely upgrade.
        MD5sums:
        9e2bbf3ddd728da4cbab3ece1ba390b7 gnupg-1.0.4-2tr.i586.rpm
        43d503eb306f202c794ca064980574ad iputils-20001011-1tr.i586.rpm
        8625657f6edea52b88e0cff1dfff4bb4 ypbind-3.3-29tr.i586.rpm
        Get them at:
        ftp://ftp.trustix.com/pub/Trustix/updates/1.1/RPMS/ or
        http://www.trustix.net/download/Trustix/updates/1.1/RPMS/
        Wirex has also released an upgrade to fix this problem for Immunix OS 6.2.
        RedHat iputils-20000418-6.i386.rpm
        
        RedHat iputils-20000121-2.i386.rpm
        
        RedHat Linux 6.2 sparc
        
        RedHat Linux 6.2 i386
        
        RedHat Linux 6.2 alpha
        
        RedHat Linux 7.0
        

- 漏洞信息

13792
iputils ping Multiple Parameter Local Overflows
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2000-10-18 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

RedHat Linux ping Buffer Overflow Vulnerability
Boundary Condition Error 1813
No Yes
2000-10-18 12:00:00 2009-07-11 03:56:00
This was first published in RedHat advisory RHSA-2000:087-02 on October 18, 2000.

- 受影响的程序版本

Wirex Immunix OS 6.2
RedHat Linux 7.0
RedHat Linux 6.2 sparc
RedHat Linux 6.2 i386
RedHat Linux 6.2 alpha
RedHat iputils-20000418-6.i386.rpm
+ RedHat Linux 7.0
RedHat iputils-20000121-2.i386.rpm
+ Red Hat Linux 6.2

- 漏洞讨论

ping is a network diagnostic tool shipped with almost every operating system. On unix/linux systems it is usually installed setuid root because it needs to open a raw socket (to send and recieve ICMP messages). The version of ping that ships with RedHat Linux (and quite possibly, though uncomfirmed, others) is vulnerable to a buffer overflow attack. The exact techincal details are not known at this time. It is reported that the overflow involves a static variable, 'buf', though it has not verified whether this this exploitable or not. It is likely that this is non-exploitable.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

RedHat has released fixed packages.

Trustix recently released several updated packages:

iputils: Fixes serveral problems in ping including a buffer overflow.
gnupg: Fixed a serious bug which could lead to false signature verification results when more than one signature is fed to gpg.

ypbind: Local root exploit. Linux ypbind

Users of TSL 1.0x and 1.1 that worry about local security should definitely upgrade.

MD5sums:
9e2bbf3ddd728da4cbab3ece1ba390b7 gnupg-1.0.4-2tr.i586.rpm
43d503eb306f202c794ca064980574ad iputils-20001011-1tr.i586.rpm
8625657f6edea52b88e0cff1dfff4bb4 ypbind-3.3-29tr.i586.rpm

Get them at:
ftp://ftp.trustix.com/pub/Trustix/updates/1.1/RPMS/ or
http://www.trustix.net/download/Trustix/updates/1.1/RPMS/

Wirex has also released an upgrade to fix this problem for Immunix OS 6.2.


RedHat iputils-20000418-6.i386.rpm

RedHat iputils-20000121-2.i386.rpm

RedHat Linux 6.2 sparc

RedHat Linux 6.2 i386

RedHat Linux 6.2 alpha

RedHat Linux 7.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站