CVE-2000-1176
CVSS7.5
发布时间 :2001-01-09 00:00:00
修订时间 :2008-09-05 16:22:50
NMCOES    

[原文]Directory traversal vulnerability in YaBB search.pl CGI script allows remote attackers to read arbitrary files via a .. (dot dot) attack in the "catsearch" form field.


[CNNVD]YaBB search.pl执行任意文件漏洞(CNNVD-200101-042)

        YaBB search.pl CGI脚本存在目录遍历漏洞。远程攻击者可以借助"catsearch"格式字段的..(点 点)攻击读取任意文件。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-1176
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-1176
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200101-042
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1921
(VENDOR_ADVISORY)  BID  1921
http://archives.neohapsis.com/archives/bugtraq/2000-11/0110.html
(VENDOR_ADVISORY)  BUGTRAQ  20001107 Insecure input balidation in YaBB Search.pl

- 漏洞信息

YaBB search.pl执行任意文件漏洞
高危 路径遍历
2001-01-09 00:00:00 2005-10-20 00:00:00
远程※本地  
        YaBB search.pl CGI脚本存在目录遍历漏洞。远程攻击者可以借助"catsearch"格式字段的..(点 点)攻击读取任意文件。

- 公告与补丁

        This issue has been addressed in the latest release of YaBB:
        YaBB YaBB 9.11.2000
        

- 漏洞信息 (20387)

YaBB 9.11.2000 search.pl Arbitrary Command Execution Vulnerability (EDBID:20387)
cgi remote
2000-11-07 Verified
0 rpc
N/A [点击下载]
source: http://www.securityfocus.com/bid/1921/info

YaBB (Yet Another Bulletin Board) is a popular perl-based bulletin board scripting package.

search. pl, one of several perl scripts which comprise YaBB, fails to properly validate user input which arguments a call to open(). 

A malicious user could supply a string containing '/../'-type sequences and shell commands. As a result of search.pl's failure to reject this type of input, it is possible to traverse the script's normal working directories, and to execute arbitrary commands on the host with the privelege level of YaBB. This can lead to an anonymous internet user gaining shell access to the host.


An attacker could easily create a malicious html form with a catsearch such as:
./../../../../../usr/bin/touch%20/tmp/foo|
		

- 漏洞信息

7697
YaBB search.pl catsearch Parameter Traversal Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality Upgrade
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

2000-11-07 Unknow
2000-11-07 Unknow

- 解决方案

Upgrade to version 1 Gold SP1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

YaBB search.pl Arbitrary Command Execution Vulnerability
Input Validation Error 1921
Yes Yes
2000-11-07 12:00:00 2009-07-11 03:56:00
Reported to bugtraq by rpc <h@ckz.org> on Tue, Nov 7, 2000.

- 受影响的程序版本

YaBB YaBB 9.11.2000
YaBB YaBB 1 Gold Release
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0

- 不受影响的程序版本

YaBB YaBB 1 Gold Release
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0

- 漏洞讨论

YaBB (Yet Another Bulletin Board) is a popular perl-based bulletin board scripting package.

search. pl, one of several perl scripts which comprise YaBB, fails to properly validate user input which arguments a call to open().

A malicious user could supply a string containing '/../'-type sequences and shell commands. As a result of search.pl's failure to reject this type of input, it is possible to traverse the script's normal working directories, and to execute arbitrary commands on the host with the privelege level of YaBB. This can lead to an anonymous internet user gaining shell access to the host.

- 漏洞利用

An attacker could easily create a malicious html form with a catsearch such as:
./../../../../../usr/bin/touch%20/tmp/foo|

(excerpted from bugtraq posting by rpc &lt;h@ckz.org&gt;)

- 解决方案

This issue has been addressed in the latest release of YaBB:


YaBB YaBB 9.11.2000

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站