CVE-2000-1172
CVSS10.0
发布时间 :2001-01-09 00:00:00
修订时间 :2008-09-05 16:22:50
NMCOS    

[原文]Buffer overflow in Gaim 0.10.3 and earlier using the OSCAR protocol allows remote attackers to conduct a denial of service and possibly execute arbitrary commands via a long HTML tag.


[CNNVD]Gaim远程缓冲区远程漏洞(CNNVD-200101-035)

        Gaim 0.10.3及其早期版本使用OSCAR协议时存在缓冲区溢出漏洞。远程攻击者可以借助超长HTML标签导致访问拒绝并可能执行任意命令。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:rob_flynn:gaim:0.10.3
cpe:/a:rob_flynn:gaim:0.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-1172
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-1172
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200101-035
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1948
(VENDOR_ADVISORY)  BID  1948
http://archives.neohapsis.com/archives/bugtraq/2000-11/0204.html
(VENDOR_ADVISORY)  BUGTRAQ  20001110 Advisory: Gaim remote vulnerability

- 漏洞信息

Gaim远程缓冲区远程漏洞
危急 缓冲区溢出
2001-01-09 00:00:00 2005-10-20 00:00:00
远程※本地  
        Gaim 0.10.3及其早期版本使用OSCAR协议时存在缓冲区溢出漏洞。远程攻击者可以借助超长HTML标签导致访问拒绝并可能执行任意命令。

- 公告与补丁

        Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 漏洞信息

8624
Gaim OSCAR Protocol Long HTML Tag Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2000-11-13 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Gaim Remote Buffer Overflow Vulnerability
Boundary Condition Error 1948
Yes Yes
2000-11-10 12:00:00 2009-07-11 03:56:00
Reported to bugtraq by Stan Bubrouski <stan@ccs.neu.edu> on November 9, 2000.

- 受影响的程序版本

Rob Flynn Gaim 0.10.3
Rob Flynn Gaim 0.10 x

- 漏洞讨论

Gaim is an interactive chat client which supports AOL's Instant Messenger service, and runs on a number of Unix-based platforms.

When set to use the OSCAR protocol, 0.10.x versions of the Gaim client up to and including 0.10.3 fail to properly size-check embedded HTML tags in received messages. Such tags, if made by an attacker to exceed approximately 4100 characters, can create a buffer overflow condition. As a result, the excessive data copied onto the stack can overwrite critical parts of the stack frame such as the calling functions' return address. Since this data is supplied by the user it can be crafted in such a way that it alters the program's flow of execution. If properly exploited, this can yield root privileges to the attacker.

For a number of reasons it is believed that this vulnerability is quite difficult to exploit. See Stan Bubrouski's (stan@ccs.neu.edu) message in the reference section for details.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any publicly available exploits for this vulnerability. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Currently the SecurityFocus staff are not aware of any vendor supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站