CVE-2000-1137
CVSS4.6
发布时间 :2001-01-09 00:00:00
修订时间 :2008-09-10 15:06:41
NMCO    

[原文]GNU ed before 0.2-18.1 allows local users to overwrite the files of other users via a symlink attack.


[CNNVD]GNU ed覆盖其他用户的文件漏洞(CNNVD-200101-088)

        GNU ed 0.2-18.1之前的版本存在漏洞。本地用户借助一个符号连接攻击覆盖其他用户的文件。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gnu:ed:2.18
cpe:/a:gnu:ed:2.16tr
cpe:/a:gnu:ed:2.15
cpe:/a:gnu:ed:2.18.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-1137
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-1137
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200101-088
(官方数据源) CNNVD

- 其它链接及资源

http://www.redhat.com/support/errata/RHSA-2000-123.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2000:123
http://xforce.iss.net/xforce/xfdb/5723
(UNKNOWN)  XF  gnu-ed-symlink(5723)
http://www.osvdb.org/6491
(UNKNOWN)  OSVDB  6491
http://www.linux-mandrake.com/en/security/MDKSA-2000-076.php3
(UNKNOWN)  MANDRAKE  MDKSA-2000:076
http://www.debian.org/security/2000/20001129
(UNKNOWN)  DEBIAN  20001129 DSA-001-1 ed: symlink attack
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000359
(UNKNOWN)  CONECTIVA  CLA-2000:359-2

- 漏洞信息

GNU ed覆盖其他用户的文件漏洞
中危 未知
2001-01-09 00:00:00 2005-05-02 00:00:00
本地  
        GNU ed 0.2-18.1之前的版本存在漏洞。本地用户借助一个符号连接攻击覆盖其他用户的文件。

- 公告与补丁

        

- 漏洞信息

6491
GNU ed tmpfile Symlink Arbitrary File Overwrite
Local Access Required Race Condition
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

GNU ed contains a flaw that may allow a malicious user to overwrite arbitrary files. The issue is triggered when a user creates a symlink to a temporary file and the system is halted before the file is saved. This flaw may lead to a loss of integrity and availability.

- 时间线

2000-12-11 Unknow
2000-12-11 Unknow

- 解决方案

Upgrade to version 0.2-19 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站