CVE-2000-1025
CVSS5.0
发布时间 :2000-12-11 00:00:00
修订时间 :2016-10-17 22:08:02
NMCOES    

[原文]eWave ServletExec JSP/Java servlet engine, versions 3.0C and earlier, allows remote attackers to cause a denial of service via a URL that contains the "/servlet/" string, which invokes the ServletExec servlet and causes an exception if the servlet is already running.


[CNNVD]Unify eWave ServletExec远程拒绝服务攻击漏洞(CNNVD-200012-060)

        
        Unify的eWave ServletExec是一个JSP和Java Servlet引擎,用作流行的web服务器如Apache、IIS、Netscape等的插件。
        eWave ServletExec处理异常请求时存在漏洞,远程攻击者可能利用此漏洞对eWave进行拒绝服务攻击。
        给ServletExec servlet引擎发送一个URL请求会导致其异常终止。可以通过在URL中加上servlet路径前缀"/servlet"来强制执行任意servlet。在服务器端的类中存在一个名为"ServletExec"的servlet。通过强制方式来执行"ServletExec"servlet将导致servlet引擎重新初始化并试图在80口上绑定一个服务器线程。如果服务器已经运行,端口绑定操作将导致一个异常,servlet引擎异常终止。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-1025
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-1025
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200012-060
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=97295224226042&w=2
(UNKNOWN)  BUGTRAQ  20001030 Unify eWave ServletExec DoS
http://www.securityfocus.com/bid/1868
(VENDOR_ADVISORY)  BID  1868
http://xforce.iss.net/static/5435.php
(UNKNOWN)  XF  ewave-servletexec-dos

- 漏洞信息

Unify eWave ServletExec远程拒绝服务攻击漏洞
中危 其他
2000-12-11 00:00:00 2005-10-20 00:00:00
远程※本地  
        
        Unify的eWave ServletExec是一个JSP和Java Servlet引擎,用作流行的web服务器如Apache、IIS、Netscape等的插件。
        eWave ServletExec处理异常请求时存在漏洞,远程攻击者可能利用此漏洞对eWave进行拒绝服务攻击。
        给ServletExec servlet引擎发送一个URL请求会导致其异常终止。可以通过在URL中加上servlet路径前缀"/servlet"来强制执行任意servlet。在服务器端的类中存在一个名为"ServletExec"的servlet。通过强制方式来执行"ServletExec"servlet将导致servlet引擎重新初始化并试图在80口上绑定一个服务器线程。如果服务器已经运行,端口绑定操作将导致一个异常,servlet引擎异常终止。
        

- 公告与补丁

        厂商补丁:
        Unify
        -----
        目前厂商已经在最新版本的软件中修复这个安全问题,请到厂商的主页下载:
        
        http://www.unifyewave.com/servletexec/

- 漏洞信息 (20336)

Unify eWave ServletExec 3.0 c DoS Vulnerability (EDBID:20336)
multiple remote
2000-10-30 Verified
0 Foundstone Labs
N/A [点击下载]
source: http://www.securityfocus.com/bid/1868/info

Unify eWave ServletExec is a Java/Java Servlet engine plug-in for major web servers such as Microsoft IIS, Apache, Netscape Enterprise Server, etc.

eWave ServletExec is susceptible to a denial of service attack if a URL invoking the ServletExec servlet preceded by /servlet is requested. The ServletExec engine will attempt to bind a server thread over port 80 and if the web server is currently running, a java.net.BindException error will result thus halting all operations on the ServletExec engine. The web server is not affected by this vulnerability. Restarting the application is required in order to regain normal functionality.

http://target/servlet/ServletExec

or 

nc 10.0.0.1 80
GET /servlet/ServletExec HTTP/1.0		

- 漏洞信息

13751
Unify eWave ServletExec JSP/Java Servlet Engine /servlet/ URL DoS
Denial of Service
Loss of Availability

- 漏洞描述

- 时间线

2000-10-30 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Unify eWave ServletExec DoS Vulnerability
Failure to Handle Exceptional Conditions 1868
Yes Yes
2000-10-30 12:00:00 2009-07-11 03:56:00
Posted to Bugtraq on October 30, 2000 by Foundstone Labs <labs@foundstone.com>.

- 受影响的程序版本

Unify eWave ServletExec 3.0 c
- HP HP-UX 11.0 4
- IBM AIX 4.3.2
- Linux kernel 2.3 .x
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 98
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0
- Sun Solaris 8_sparc

- 漏洞讨论

Unify eWave ServletExec is a Java/Java Servlet engine plug-in for major web servers such as Microsoft IIS, Apache, Netscape Enterprise Server, etc.

eWave ServletExec is susceptible to a denial of service attack if a URL invoking the ServletExec servlet preceded by /servlet is requested. The ServletExec engine will attempt to bind a server thread over port 80 and if the web server is currently running, a java.net.BindException error will result thus halting all operations on the ServletExec engine. The web server is not affected by this vulnerability. Restarting the application is required in order to regain normal functionality.

- 漏洞利用

http://target/servlet/ServletExec

or

nc 10.0.0.1 80
GET /servlet/ServletExec HTTP/1.0

- 解决方案

According to the Foundstone advisory, version 3.0E of eWave ServletExec is not susceptible to this vulnerability. The following download page was provided in the advisory, however as of October 30, 2000, version 3.0E is not available:

http://www.servletexec.com/downloads/

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站