CVE-2000-0957
CVSS7.5
发布时间 :2000-12-19 00:00:00
修订时间 :2008-09-10 15:06:13
NMCO    

[原文]The pluggable authentication module for mysql (pam_mysql) before 0.4.7 does not properly cleanse user input when constructing SQL statements, which allows attackers to obtain plaintext passwords or hashes.


[CNNVD]mysql漏洞(CNNVD-200012-089)

        mysql (pam_mysql) 0.4.7之前版本的可插入认证模型在构造SQL语句时不能正确净化用户输入。攻击者获得纯文本密码或者无用信息。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:pam_mysql:pam_mysql:0.3
cpe:/a:pam_mysql:pam_mysql:0.2
cpe:/a:pam_mysql:pam_mysql:0.4
cpe:/a:pam_mysql:pam_mysql:0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0957
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0957
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200012-089
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/5447.php
(VENDOR_ADVISORY)  XF  pammysql-auth-input
http://archives.neohapsis.com/archives/bugtraq/2000-10/0374.html
(VENDOR_ADVISORY)  BUGTRAQ  20001026 (SRADV00004) Remote and local vulnerabilities in pam_mysql

- 漏洞信息

mysql漏洞
高危 未知
2000-12-19 00:00:00 2006-11-14 00:00:00
远程  
        mysql (pam_mysql) 0.4.7之前版本的可插入认证模型在构造SQL语句时不能正确净化用户输入。攻击者获得纯文本密码或者无用信息。

- 公告与补丁

        

- 漏洞信息

7245
MySQL Pluggable Authentication Module (pam_mysql) Password Disclosure
Information Disclosure
Loss of Confidentiality Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2000-10-26 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.4.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站