发布时间 :2000-12-19 00:00:00
修订时间 :2008-09-05 16:22:15

[原文]Kootenay Web KW Whois 1.0 CGI program allows remote attackers to execute arbitrary commands via shell metacharacters in the "whois" parameter.

[CNNVD]Kootenay Web KW Whois漏洞(CNNVD-200012-109)

        Kootenay Web KW Whois 1.0 CGI程序存在漏洞。远程攻击者借助“whois”参数的shell元字符执行任意命令。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  kw-whois-meta
(VENDOR_ADVISORY)  BUGTRAQ  20001029 Re: Remote command execution via KW Whois 1.0 (addition)
(UNKNOWN)  BUGTRAQ  20001029 Remote command execution via KW Whois 1.0

- 漏洞信息

Kootenay Web KW Whois漏洞
危急 未知
2000-12-19 00:00:00 2006-09-22 00:00:00
        Kootenay Web KW Whois 1.0 CGI程序存在漏洞。远程攻击者借助“whois”参数的shell元字符执行任意命令。

- 公告与补丁


- 漏洞信息 (20370)

Kootenay Web Inc whois 1.0 Remote Command Execution Vulnerability (EDBID:20370)
cgi remote
2000-10-29 Verified
0 Mark Stratman
N/A [点击下载]

whois is a utility used to find general information and technical details about registered domain names. A vulnerability exists in Kootenay Web Inc's Whois (release v.1.9), a web interface to whois running on a linux server. 

Due to a failure to properly check user-supplied input to a form variable for shell metacharacters, a malicious remote user can trick the script into executing arbitrary code on the host system. At that point an attacker can gain local shell access to the system with the privileges of the webserver. Further compromise (eg, root) may follow.

Unsafe code:
$site = $query->param('whois');
$app = `whois $site`;
print "$app .......

Proof of concept:
Type ";id" (without the quotes) into the input box.		

- 漏洞信息

KW Whois CGI whois Parameter Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

2000-10-29 Unknow
2000-10-29 Unknow

- 解决方案

Upgrade to version 1.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete