CVE-2000-0918
CVSS7.2
发布时间 :2000-12-19 00:00:00
修订时间 :2008-09-05 16:22:11
NMCOS    

[原文]Format string vulnerability in kvt in KDE 1.1.2 may allow local users to execute arbitrary commands via a DISPLAY environmental variable that contains formatting characters.


[CNNVD]KDE kvt格式化字符串漏洞(CNNVD-200012-106)

        KDE 1.1.2版本的kvt存在格式化字符串漏洞。本地用户借助包含格式化字符的DISPLAY环境变量执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0918
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0918
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200012-106
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/1700
(VENDOR_ADVISORY)  BID  1700
http://www.securityfocus.com/archive/1/83914
(PATCH)  BUGTRAQ  20000919 kvt format bug

- 漏洞信息

KDE kvt格式化字符串漏洞
高危 格式化字符串
2000-12-19 00:00:00 2005-10-20 00:00:00
本地  
        KDE 1.1.2版本的kvt存在格式化字符串漏洞。本地用户借助包含格式化字符的DISPLAY环境变量执行任意命令。

- 公告与补丁

        Carlos Eduardo Gorges has supplied a patch he wrote that will fix the problem in his post to Bugtraq. Since kvt is no longer supported and will be obsoleted when KDE 2.0 is released, it is suggested that users use this patch.
        KDE kvt 1.1.2
        

- 漏洞信息

12989
KDE kvt Format String Arbitrary Local Command Execution
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

1999-06-08 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

KDE kvt Format String Vulnerability
Input Validation Error 1700
No Yes
2000-09-19 12:00:00 2009-07-11 03:56:00
Posted to Bugtraq by Carlos Eduardo Gorges <carlos@techlinux.com.br> on September 19, 2000.

- 受影响的程序版本

KDE kvt 1.1.2
+ KDE KDE 1.1.2

- 漏洞讨论

kvt is a terminal emulation program for X-Windows written using Qt. Like other such programs, it is usually installed setuid root so that it can have its own psuedo-terminal and write to utmp/wtmp. kvt contains a format-string vulnerability that may make it possible to for local users to obtain super-user priviliges. kvt assigns the value of the user-definable DISPLAY environment variable to a character buffer, which it then uses as the only argument to a *printf() function later in the program. It is not known whether this can be used to exploit kvt or not.

This bug may affect rxvt as well, since kvt is derived from the rxvt source.

- 漏洞利用

Currently the SecurityFocus staff are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

- 解决方案

Carlos Eduardo Gorges <carlos@techlinux.com.br> has supplied a patch he wrote that will fix the problem in his post to Bugtraq. Since kvt is no longer supported and will be obsoleted when KDE 2.0 is released, it is suggested that users use this patch.


KDE kvt 1.1.2

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站