CVE-2000-0900
CVSS7.5
发布时间 :2000-12-19 00:00:00
修订时间 :2008-09-05 16:22:08
NMCO    

[原文]Directory traversal vulnerability in ssi CGI program in thttpd 2.19 and earlier allows remote attackers to read arbitrary files via a "%2e%2e" string, a variation of the .. (dot dot) attack.


[CNNVD]thttpd ssi CGI程序目录遍历漏洞(CNNVD-200012-114)

        thttpd 2.19及其早期版本的ssi CGI程序存在目录遍历漏洞。远程攻击者借助"%2e%2e"字符串读取任意文件,该漏洞是 .. (点 点)攻击的变体。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:acme_labs:thttpd:2.18
cpe:/a:acme_labs:thttpd:2.16
cpe:/a:acme_labs:thttpd:2.17
cpe:/a:acme_labs:thttpd:2.19

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2000-0900
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2000-0900
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200012-114
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/static/5313.php
(VENDOR_ADVISORY)  XF  acme-thttpd-ssi
http://www.securityfocus.com/bid/1737
(VENDOR_ADVISORY)  BID  1737
http://archives.neohapsis.com/archives/bugtraq/2000-10/0025.html
(VENDOR_ADVISORY)  BUGTRAQ  20001002 thttpd ssi: retrieval of arbitrary world-readable files
ftp://ftp.FreeBSD.org/pub/FreeBSD/CERT/advisories/FreeBSD-SA-00:73.thttpd.asc
(UNKNOWN)  FREEBSD  FreeBSD-SA-00:73

- 漏洞信息

thttpd ssi CGI程序目录遍历漏洞
高危 路径遍历
2000-12-19 00:00:00 2006-08-03 00:00:00
远程  
        thttpd 2.19及其早期版本的ssi CGI程序存在目录遍历漏洞。远程攻击者借助"%2e%2e"字符串读取任意文件,该漏洞是 .. (点 点)攻击的变体。

- 公告与补丁

        

- 漏洞信息

422
thttpd ssi Servlet Encoded Traversal Arbitrary File Access
Remote / Network Access Information Disclosure
Loss of Confidentiality Upgrade
Vendor Verified

- 漏洞描述

This host is running a web server. This server contains a flaw that allows an attacker to read arbitrary files on this host by prefixing pathnames with %2e%2e/. An attacker can use this to gain information about this host.

- 时间线

2000-10-02 Unknow
2000-10-02 Unknow

- 解决方案

Upgrade to version 2.20 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站